Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

While the game itself runs smoothly and I can watch the cutscenes using the bink player without problems, their ingame playback fails to produce sound every other second (quite periodically actually). What's the problem and how can I fix this?

share|improve this question
    
What are your system specs? And I assume you use a motherboard based sound card right? –  Ids Sep 30 '12 at 17:15
    
@Ids Yes, it's a Realtek onboard sound "card". But since neither the game's sound nor the directly played movies cause trouble, I'd be surprised if it was a hardware issue –  Zommuter Sep 30 '12 at 17:27
    
onboard sound can stutter when the system is getting overloaded. Perhaps it keeps running torchlight in the background while playing the movie. That was why I asked. –  Ids Sep 30 '12 at 18:18
    
@Ids interesting point, but I just checked and the movie plays fine via bink player even with Torchlight running in background. An AMD Phenom II X3 720 @ 2.8 GHz shouldn't have trouble with that anyway... –  Zommuter Sep 30 '12 at 18:47
1  
It's a common problem and sometimes seems to be fixed by turning down shadows. The dev said he was going to look at it so it's most likely a bug of some sorts. Another post mentioned sound stuttering and fixed it by upping the priority of Torchlight (nice command for Linux, taskmanager can do that in Windows I believe). –  Aerus Sep 30 '12 at 21:40

1 Answer 1

up vote 1 down vote accepted

As seen in this post on the Runic Games forums it's a known issue and quite a few people have a problem with it and the cause seems not known (yet), although a dev said he would look at the issue.

A first, possible solution is to turn down your Shadows setting. For some people this solves the problem. If this doesn't work, you can try to turn down other graphics such as Bloom (as mentioned by the OP) down aswell.

If this doesn't solve the problem either (or for people playing Torchlight II on Linux in Wine and having sound issues) it can help to increase the program's priority.
In Windows this can be done by simply launching Torchlight II and looking up torchlight2.exe in the Processes tab of the Task Manager. Once you found the process, right-click it and select Set priority > High.
In Linux this can be done by using the nice command to launch Torchlight II with Wine.

share|improve this answer
    
In my case, Bloom and Shadows had to be deactivated, while changing the process priority didn't do anything. –  Zommuter Oct 2 '12 at 7:35
    
To save anyone else the trouble, I tried all of the above. Nothing worked. Still no solution to this I've been able to find at least. –  user38807 Dec 24 '12 at 15:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.