Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have seen this asked multiple times all over the internet but haven't found a proper answer to this yet.

Whenever I'm in third person view I experience major input lag on character movement, i.e., whenever I use WASD or my 360 controller's control stick it takes about 0.5 seconds for my character to actually move. However, in first person the character responds instantly.

What I have tried:

  • Valve's tips on input lag
  • Disable V-Sync (iPresentInterval=0)
  • Uninstall all mods
  • Delete .ini files (reset to default)
  • Install proper keyboard driver
  • Unplug controller (still lag using keyboard)
  • Unplug keyboard (still lag using controller)

Other actions still respond instantly, including jumping, opening the menu or interacting with actors. It's really just the movement keys.

I haven't played Skyrim since 1.2 but I can't remember ever having issues with this. Same hardware as back then, too (GTX 570, i5-2500K).

Any solutions to this problem? Could this even be intentional?

Edit: So, after some getting used to, the delay feels sort of normal and is tolerable. Considering that this only affects the movement keys, I'm really starting to think this is intentional and has always been there, possibly to avoid choppy animation. Still, if anyone has found a way to remove the delay I'd be very thankful.

Edit#2: Just a quick repost of what I wrote in a comment to The Nerger's answer: I contacted the SKSE devs about it, thinking it would be a code issue. This was their response:

I haven't investigated the issue, but my first guess would be that player movement, especially in third person, is driven by animation. The animation system passes the expected movement for each movement back to the physics and gameplay code, leading to the player moving around. So that the player looks less stupid in third-person view, there's some acceleration when starting to move.

Fixing this would be a data-side fix rather than a code-side fix.

Not sure if this helps but it would be nice to hear from some experienced modders about this issue.

share|improve this question
1  
+1 because this is how you ask a good question. As far as performance lag, I can try playing in 3rd person and post my findings. –  ヴァイシャリ Oct 2 '12 at 16:26
    
Play in first person... This isn't Tomb Raider ;) (edit and play with keyboard and mouse!) –  Neurofluxation Oct 18 '12 at 8:28
    
@Opossum (and anyone else with the same issue) Do you have 'triple buffering' in your videocard drivers enabled? –  galacticninja Mar 20 '13 at 5:25
    
I've heard PC Skyrim is like known for lag. +1! Great question. –  BacoTell Apr 8 '13 at 22:03

3 Answers 3

Check video card drivers. Try checking Windows mouse and keyboard settings for irregularities. Reinstalling keyboard/mouse drivers. Trying a different keyboard or mouse. Finally DirectX 8 might be responsible. DirectX 8 source - http://www.theofpfaq.ashnav.co.il/trouble/inputdelay.htm Other Information Source - https://support.steampowered.com/kb_article.php?ref=5365-RXBN-5508

share|improve this answer

This is an educated guess, but when you are in third-person, the system needs more time to render the character's body, weapons, and actions than when it only has to render the arms of the character.

If Bethesda didn't optimize the code enough for the third person view (maybe they assumed that most playing time would be spent in first-person) then that might account for the lag. Of course, if this is the case, then there isn't anything that we can do about it, except to pester Bethesda about updating it in a patch.

From this search I think it's pretty clear that many people are having this problem, and that there is not good solution as of now.

share|improve this answer
1  
You're not really addressing the issue at all; you're guessing why it might be happening, but you offer no solution to resolving the issue. –  Frank Nov 2 '12 at 18:18
4  
Also, this guess is extremely unlikely to be factually correct. There's no reason that adding one more actor to the render job, or moving the viewport camera, is going to have an impact on the order of ~15 frames of gamepad input delay while other input devices are unaffected and nothing else in the game is negatively affected. –  SevenSidedDie Nov 2 '12 at 19:44
    
My attempt at a solution was to pester Bethesda to patch it. It is a solution, though it is one that will not be immediately resolved. Has anyone looked for mods that attempted to fix this? –  The Nerge Nov 2 '12 at 20:56
4  
@JayNerger I contacted the SKSE devs about it, thinking it would be a code issue. This was their response: "I haven't investigated the issue, but my first guess would be that player movement, especially in third person, is driven by animation. The animation system passes the expected movement for each movement back to the physics and gameplay code, leading to the player moving around. So that the player looks less stupid in third-person view, there's some acceleration when starting to move. Fixing this would be a data-side fix rather than a code-side fix." –  Opossum Nov 3 '12 at 14:39
    
@Opossum That sounds like a very plausible reason (and the SKSE team know the internals of Skyrim probably better than anyone who isn't at BethSoft). Want to post it as an answer? I'd vote it up! –  SevenSidedDie Oct 11 '13 at 18:15
  1. Navigate to \Program Files\Steam\steamapps\common\skyrim\Skyrim
  2. Open SkyrimPrefs.ini in Notepad.
  3. Locate [Controls] and then find 'bMouseAcceleration=1'
  4. Change bMouseAcceleration=1 to bMouseAcceleration=0

This will disable "mouse smoothing" and "mouse acceleration" in Skyrim. It's possible this could be the culprit as it seems you have tried just about everything else.

Various people have also reported success using D3D antilag to limit the number of frames ahead your video card renders and also limit the frames per second. The goal being to reduce overall input lag. Recommended settings for Skyrim are RenderAheadLimit=0 and FPSlimit=57.

Finally the if nothing works it's quite possible what you are describing is intentional The game employs independent mouse sensitivities for the vertical and horizontal axes and as such your input when moving horizontally is slightly less sensitive than when moving vertically. This would have been a conscious design choice the developers made in order to prevent big performance hits as panning the camera around very quickly in 3rd person in an environment with very high draw distances could cause stuttering or big dips in frame rate even on quite powerful machines.

As a response you could try to alter your FoV or Field of View, so you see slightly less of the environment at the edges of your screen, cutting down on the amount of scenery your card has to render per frame. Full explanation, comparison screenshots and instructions here.

There are a number of further performance tweaks you can make to the .ini files which could potentially lessen this effect you are seeing.

share|improve this answer
    
I'm not sure reduce the frame buffer to 0 is a good idea - it will likely lead to tearing (if VSync is off) or a loss in performance (if VSync is on). –  kotekzot Dec 5 '12 at 22:04
2  
Mouse lag or performance (frame) lag is not the issue as I'm running the game on a decent frame rate with all sorts of graphics mods enabled. I get the same delay when playing without mods. As I said, the only input that is affected by this is movement (WASD or control stick on a game-pad), again leading to the conclusion that this is probably an intended feature rather than performance lag. I stopped playing Skyrim a while ago but thanks for your input nonetheless. Others might still want this resolved. –  Opossum Dec 9 '12 at 17:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.