Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

In Civ4 I would improve the key points around a city to be how I wanted them and then normally stick a worker in to the mode that would improve just that city, with workers do not remove forests and workers do not touch old improvements both enabled in the global options. I'd occasionally just stick a worker on to improve city around one I've captured that I've captured and am not interested in micromanaging.

All three of these options seem to be missing from Civ 5.

I don't want to automate my workers to work globally, as I hate them touching the stuff I've actually taken the time to configure myself, they remove too many forests for my liking, and I don't like them walking about the map all over the place (for safety and because I like my workers spread across the nation, not all bunched up irrigating one city).

So, are these options available anywhere in Civ 5?
If not, can I emulate them at all?

Update

On 22nd Oct 2010 the game was patched to version 1.0.0.62, which has added a option to the ingame menus so force workers to not change manually created improvements. I believe that they will still overwrite improvements previously created by automated workers.

share|improve this question

1 Answer 1

up vote 6 down vote accepted

As you've said, there does not appear to be any kind of "Automate City" or "Leave Forest option" available either in the game or in any config files.

UPDATE: The recent patch (around 10/28/2010) has added "Workers leave manually built improvements" to the in-game options menu. All you have to do is start the game and steam will download it for you.

As you've said these options are not available from within the game. Based on my research, sadly, both "Leave Forests" and "Automate City" seem to be completely missing. However, you can switch on "Leave Existing Improvements" by editing a config file.

  • Navigate to "My Documents/My Games/Sid Meier's Civilization V/"
  • Open "UserSettings.ini"
  • Find "AutoWorkersDontReplace = 0", it was the 5th row (3rd real setting) for me.
  • change the "= 0" (off) to "= 1" (on).

There's some small chance that this option also forces them to leave forests, but I have not tested it in the slightest. If anyone else does test it please let us know!

share|improve this answer
    
You are corect; the config option is listed as "Usersettings.ini" as mentioned here: gaming.stackexchange.com/questions/7826/… –  Raven Dreamer Oct 8 '10 at 20:10
    
@Raven thanks! That's exactly where I got my guess from. There's one other file I thought it could be, but that turns out to be just video options. –  WillfulWizard Oct 9 '10 at 8:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.