Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Borderlands 2 has an annoying "performance" trick where it first loads ugly, extremely low-resolution images over new items like Ammo or new guns before high-res textures are loaded over them. It's very noticeable. I'm running on a top-end rig with zero problems running all settings maxed, so it's not a setting in the normal video options.

Since I'm on the PC version, is there some config file or video card setting magic I need to perform to fix these unsightly textures?

share|improve this question
    
Other Borderlands 2 PC version fixes here: pcgamingwiki.com/wiki/Borderlands_2 –  galacticninja Oct 2 '12 at 16:30

1 Answer 1

up vote 5 down vote accepted

This was such a problem that it's now just a normal setting in the Video settings. Just go into the options menu into Video settings and change "Texture Fade" to Off and high res textures will be loaded the first time, for no fade in.

The method below works but it's more of a "hack" than just using the in-game option. It used to be the only way to change it.


If you’ve noticed texture pop-up when you open loot containers and it’s irritating you, you can greatly reduce it or eliminate it with this using a trick found How to Improve Borderlands 2 with .ini File Tweaks.

Find the file located at C:\Users\%USERNAME%\Documents\My Games\Borderlands 2\WillowGame\Config\WillowEngine.ini. You can edit this file safely with any text editor (notepad).

As Gamefront notes, you can change the following set of settings (ctrl F to find them)

MipFadeInSpeed0=0.3
MipFadeOutSpeed0=0.1
MipFadeInSpeed1=2.0
MipFadeOutSpeed1=1.0

To all zeros, like so:

MipFadeInSpeed0=0
MipFadeOutSpeed0=0
MipFadeInSpeed1=0
MipFadeOutSpeed1=0

If you're scared you can make a backup copy of your text file, but the above are the defaults (not the zeros) so you can set them back or play with them as you like. If you notice a significant performance drop (I certainly haven't) you can restore the settings.

The link has some other tweaks that may improve aesthetics or performance for the more picky. But this issue bugs the most people I know of.

share|improve this answer
    
I'm not even sure why they bother having "fade-in" with mip-maps, in most games it's subbed in instantly, the idea being that the player cannot notice the quality change when distance changes. –  Sadly Not Oct 2 '12 at 8:41
    
@toNyldaS even weirder these are fade ins for items that appear less than a meter away from you...it's extremely noticeable when they appear, not one of those "oh it's way in the background anyway" things –  Ben Brocka Oct 2 '12 at 12:41
1  
According to the PCGamingWiki.com 'Borderlands 2' article, only MipFadeInSpeed0 and MipFadeInSpeed1 need to be set to 0. –  galacticninja Oct 2 '12 at 16:31
    
@galacticninja that makes sense, I hadn't noticed the fade out settings. I'll try setting those back –  Ben Brocka Oct 2 '12 at 19:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.