Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

For some reason whenever I'm in Opportunity and I look around at all the buildings, my FPS drops to below 40, sometimes 30. Opportunity isn't the only place it happens, but it's most notable there.

My PC specs:

  • AMD Phenom II X4 965 @ 3.68Ghz
  • Radeon HD 7950
  • 16Gb DDR3 RAM
  • 128Gb SSD

As you can see this is a pretty high end PC. I have updated all my drivers, so please don't tell me to.

Note: I just noticed this happening even more in Thousand Cuts, if you go to the Hyperion barrier and look over the Slab fortress.

share|improve this question
    
It's probably just one of the more CPU intensive areas. I notice lag in the first part of Caustic Caverns but no where else, personally. –  Ben Brocka Oct 6 '12 at 23:05
    
So you think upgrading my CPU would fix it? I'm going to get a AMD Piledriver when it comes out. –  ryansworld10 Oct 6 '12 at 23:36
    
What are your video/graphics settings? –  galacticninja Oct 7 '12 at 3:48
    
@galacticninja Everything max except for PhysX (low) –  ryansworld10 Oct 7 '12 at 4:00
    
RE upgrading your CPU I doubt kinda it, I'm OC'd at 4 Ghz and a Raedon 6950. Any upgrade beyond that will cost you a fair amount of dough, and most games don't seem to take advantage of 8 cores. I'm sure some degree of amazing CPU and GPU would fix it, but I think it'd have to be a very substantial upgrade. –  Ben Brocka Oct 7 '12 at 15:38
show 1 more comment

1 Answer 1

up vote 5 down vote accepted

Do you have PhysX set to higher than 'low' in your video settings? If yes, try setting it to low as you might have a large performance hit due to the fact that the PhysX would be CPU-bound if you have an AMD GPU. (Source: PC Gaming Wiki; Borderlands 2 - PhysX)

I'd also try setting the framerate option to 'Smoothed 22-62'. What it does is try to maintain your frame rate between 22-62, automatically adjusting the engine (graphics, effects, draw distance, etc) on-the-fly, to try to maintain this frame rate in parts where your PC starts to drop the frame rate below the minimum (22fps). Source: Steam forum post on 'Capped 60, smoothed 22-62, or unlimited+vsync on?' thread

If that still doesn't work for you, try changing the framerate setting to 'Unlimited' instead. Then, try changing MinDesiredFrameRate from 35 to 60 in WillowEngine.ini in the USERS directory: C:\Users\%USERNAME%\Documents\My Games\Borderlands 2\WillowGame\Config\. It may result in the expected performance from high-powered hardware. (Source: PC Gaming Wiki; 'Borderlands 2 - Microstutter on Powerful Rigs')

share|improve this answer
    
I have PhysX on low. Turning down the graphics automatically isn't an option, as it doesn't fix the issue. I'll try the third one. –  ryansworld10 Oct 7 '12 at 4:02
    
Tweaking that setting seems to have greatly improved my performance. Thanks! –  ryansworld10 Oct 7 '12 at 4:50
    
@ryansworld10 I'm glad it helped. By the way, what setting did you set the framerate option to? Did you set it to 'Unlimited', or another option? –  galacticninja Oct 7 '12 at 4:58
1  
I have it set to cap at 60, Vsync on. I know it can hurt performance slightly, but screen tearing is so freaking annoying. –  ryansworld10 Oct 7 '12 at 5:15
    
It looks like I'm still having the frame drop issue when looking at large areas. After experimenting, I just noticed that this happens regardless of my graphics settings. Therefore, it is probably my CPU. That third fix did fix frame drops during combat though :) –  ryansworld10 Oct 7 '12 at 15:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.