Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

So here's my rig: Windows 7 Ultimate 64bit. AMD Phenom II x4 810 (2.6gHz) 4gb DDR2-800 AMD Radeon 5850 1gb, connected via HDMI to a Samsung 47" 1080p LCD TV.

I can play other games fine, though the ones I play the most are Civ V and UT3. However, Crysis exhibits an odd stuttering...

It will run incredibly smoothly, with frame rates often in excess of 50fps. However, about once a second, there's a small hitch or stutter. This is the only game I've seen this behavior in. This is not the microstutter exhibited by SLI systems, as I don't run SLI. I doubt it's texture streaming, as it occurs too often and too reliably (texture streaming stutters should occur when moving, yet this occurs even if I'm standing still). It occurs no matter what settings I use, whether 1080p w/ everything on Highest, or 800x600 w/ everything on Low. I've tried disabling all background programs except my Norton antivirus. If I can't find other solutions, I'll try disabling that - after I first disable my network connection. Sorry, I don't think gaming is important enough to compromise the security of your PC. Any other ideas about what could be causing this problem?

share|improve this question
    
It could be that Crysis is still too much for your impressive (as of 2010) machine. It is Crysis after all...I would not expect any machine from 2010 to be able to completely handle Crysis, similar to what we saw when Doom 3 first came out. –  Elpezmuerto Oct 13 '10 at 18:20
    
Try just disabling your network connection. The internet does strange things. –  GnomeSlice Oct 13 '10 at 18:29
    
That is what we call in programming circles "bad programming." It is easy to make a game that looks good and can't run on current computers; making it look good AND runnable is the challenge... –  BlueRaja - Danny Pflughoeft Oct 13 '10 at 19:07
2  
Also, read up on Norton - while it does significantly reduce the performance of your pc, it doesn't make your pc significantly more secure: codinghorror.com/blog/2007/02/… –  MGOwen Oct 21 '10 at 2:50
3  
Oh wow, Norton. Practically the culprit to anything, including world hunger. –  sinni800 Feb 14 '11 at 12:33

3 Answers 3

I had exactly the same problem. Alter the hz rate of your sound card. (its in the audio properties of your PC, not Crysis itself). Its under the advanced tab. Try setting it to 16bit 44100hz. If it is already that, just change it up one or down one. Worked for me.

share|improve this answer

Some things to try:

  • Restart your PC and close all programs (definitely including anti-virus software - these can be very invasive and often have a fairly large and unpredictable performance impact)
  • Update Crysis and all drivers to the latest version (including sound card and motherboard drivers - not just the graphics card)
  • Check the temperature of your system (including the graphics cards) and make sure that it is well ventilated. If you find that you only start to experience problems after a few minutes of gameplay then this is a strong indication of overheating.
  • Try disabling sound
  • You should check the memory use of your PC both before you start Crysis and while Crysis is running - high memory use could easily cause this sort of problem.
  • This forum thread suggests enabling "No execute memory protect" in the BIOS.

Having read a couple of forum posts my best bet would be that the sound card it the source of the problem, but I'm really not sure.

share|improve this answer

I have nearly the identical setup (win7 64-bit 6gb + amd x4 3.2ghz + radeon 5750 + 1920x1200) and also notice some hiccups but they mostly occur when I quick-save or before some catastrophic event such as a mountain collapsing - nothing at all like you're describing.

Try using Process Hacker and this guide to see if even after "disabling all background processes", any other offending processes are still running. Who knows, maybe it's Norton scanning every file Crysis opens? If you don't want to disable Norton, consider adding an exclusion filter explicitly for your Crysis directory.

Defragment the drive where the Crysis is installed. Perhaps even consider re-installing to another drive to see if anything improves.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.