Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Minecraft has crashed!

  ----------------------      

Minecraft has stopped running because it encountered a problem; Failed to start game This error has been saved to /home/waffleman1230/.minecraft/crash-reports/crash-2012-11-06_09.58.46-client.txt for your convenience. Please include a copy of this file if you report this crash to anyone.

--- BEGIN ERROR REPORT bd657a7e --------
Generated 11/6/12 9:58 AM

- Minecraft Version: 1.4.2
- Operating System: Linux (amd64) version 3.2.0-32-generic
- Java Version: 1.6.0_24, Sun Microsystems Inc.
- Java VM Version: OpenJDK 64-Bit Server VM (mixed mode), Sun Microsystems Inc.
- Memory: 889612104 bytes (848 MB) / 1029046272 bytes (981 MB) up to 1908932608 bytes (1820 MB)
- JVM Flags: 2 total; -Xmx2048M -Xms1024M
- AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
- LWJGL: 2.4.2
- OpenGL: ~ERROR~ NullPointerException: null
- Is Modded: Probably not
- Type: Client
- Texture Pack: ~ERROR~ NullPointerException: null
- Profiler Position: N/A (disabled)
- Vec3 Pool Size: ~ERROR~ NullPointerException: null[failed to get system properties (java.lang.NullPointerException)]


org.lwjgl.LWJGLException: Could not init GLX
    at org.lwjgl.opengl.LinuxDisplayPeerInfo.initDefaultPeerInfo(Native Method)
    at org.lwjgl.opengl.LinuxDisplayPeerInfo.<init>(LinuxDisplayPeerInfo.java:52)
    at org.lwjgl.opengl.LinuxDisplay.createPeerInfo(LinuxDisplay.java:684)
    at org.lwjgl.opengl.Display.create(Display.java:854)
    at org.lwjgl.opengl.Display.create(Display.java:784)
    at org.lwjgl.opengl.Display.create(Display.java:765)
    at net.minecraft.client.Minecraft.a(SourceFile:232)
    at net.minecraft.client.Minecraft.run(SourceFile:515)
    at java.lang.Thread.run(Thread.java:679)
--- END ERROR REPORT 14dcf1c6 ----------

I even tried giving it more RAM, but that didn't help.

share|improve this question
1  
What have you tried to do to fix this? You've added RAM, I see. Anything else? Googled the basic error message? –  Frank Nov 6 '12 at 15:08
    
Are you using a custom texture pack? –  fredley Nov 6 '12 at 15:09
    
May be related to bug report MC-1384: mojang.atlassian.net/browse/MC-1384 –  Yamikuronue Nov 6 '12 at 16:28
    
There is not enough information here to be able to solve the issue. To that end, I have voted to close this until it has been provided. –  Frank Dec 14 '12 at 20:07
add comment

closed as not a real question by Frank, authenticgeek, kotekzot, Jupotter, Sean Dec 15 '12 at 10:34

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

From what I can see, the report states Null Pointer Exceptions for both OpenGL and the Texture Pack.

To me this suggests that you may not have OpenGL installed (or not correctly configured) - perhaps you're missing a video driver for you particular graphics hardware. Ensure that your video card drivers are installed and/or up to date. For AMD and Nvidia graphics cards, you will need to install the closed-source driver provided by the manufacturer - Ubuntu usually displays a warning/notification about this near the top bar.

As for the texture pack: perhaps you are using a custom pack that is either buggy or become corrupted? Try removing any texture packs from the texture pack folder.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.