Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I just started playing Killing Floor on my Desktop, then I moved over to playing it on my laptop. I was pretty happy to see that my progress was transfered over automatically to my laptop when I installed it via Steam.

The problem is that it doesn't seem like I'm ever gaining any experience. For example in one game I was playing online and gained level 3 Medic. At the end of the game, I left the server and joined a new one to find I was only level 2 Medic.

I noticed the same thing happening when I was playing a Solo game. What's going on here?

Edit: So far I've tried:

  • Verifying the game cache files in Steam.
  • When that didn't work, I tried reinstalling the game.
  • There are no mutators on, and I'm playing on KF-Manor, KF-WestLondon, KF-Farm
  • I've tried multiple servers online, and solo games.
  • The Desktop was running Windows, my laptop is running OSX.

Edit 2: I just noticed that at the end of one solo game my stats have improved, but by the time the next map loads they have reset. This is the same for multiplayer games.

share|improve this question
1  
Have you tried restarting your computer then loading the game again? Also, make sure there are no mutators on as those negate experience gain. –  hammythepig Nov 11 '12 at 19:15
1  
@hammythepig, Yessir, updated the question with steps I've tried. –  omghai2u Nov 11 '12 at 19:25
    
kk thanks! hmmm, have you tried playing again on your desktop? see if it still tracks exp there or not –  hammythepig Nov 11 '12 at 19:31
    
@hammythepig can't test it on my desktop now, I'm in currently in a different country than my desktop. :/ –  omghai2u Nov 11 '12 at 19:33
    
alright, well I know that this is a common problem, I've heard about it a lot and it even happened to me a couple times before. I got into the habit of not leaving a server until the next map was loaded and it seemed to have saved all my experience then. other than that I don't have a sure answer :/ –  hammythepig Nov 11 '12 at 19:37

2 Answers 2

up vote 2 down vote accepted

It seems pretty clear on the TripWire forums that this problem is related to it being on Mac. And from looking there and reading what others have to say, the problem has existed for years now.

It's probably pretty safe to assume that TripWire has no intention of fixing this given their track record. I guess the work-around is to use Windows or to buy games from legitimate companies. :(

share|improve this answer

Old post but since the problem still exists I will post the solution that worked for me.

I'm running KF via steam on Ubuntu 14.04 and after some games my XP started reseting.

I tried a clean install, verify game cache, etc. Nothing worked.

Ends up that in Mac and Linux when you join a server that has mutators (addons) they are downloaded in the wrong location, than a security error occurs and you gained XP is lost after you leave the game.

I found a script that fixed the problem, it basically moves the mutator files to the right folders. Unfortunately you need to run it after downloading NEW mutators.

The script can be found here :http://forums.tripwireinteractive.com/showthread.php?t=94109

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.