Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I was simply playing Dawnguard. I had just finished the entire Dawnguard questline when I saved and got off for about 2 hours. When I got back on, I tried to load my last saved game but it said something like 'saved game is corrupted'. I have already deleted the DLC and redownloaded, but it still won't work.

share|improve this question
6  
This is likely your savegame being corrupted, not the DLC. Keeping multiple saves of a Bethesda game is kinda necessary, because sadly this sort of thing happens. –  SevenSidedDie Nov 12 '12 at 0:41
1  
Have you tried to use a different savegame or make a new one? –  Andalur Nov 12 '12 at 11:45

1 Answer 1

As the message says: "saved game is corrupted" (it's not a DLC problem). You should start from another save point previous to that one because everything that you save after that (if you can save anything at all) will still be corrupted in a way or another. Always keep several save points in any game, specially Bethesda games (mainly Fallout series). If you have no previous save point I'm afraid to say that you will have to begin a new campaign.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.