Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Overview

So, I'm playing Tekkit and Technic, and it seems like there is horrible lag. The lag is so terrible that I died trying to kill a wolf on Peaceful. I have an average of 2-3 fps for the first ~5 minutes. Once the chunks are all loaded and ready to go, I have an average of 7-13 frames per second. This is very little, considering that in normal vanilla, I average 30-50 fps.

What I have already done

I have already removed two mods, I believe one of them was Mo'Creatures and the other one was MatAmos (or whatever that is). This has increased it from unplayable to a maximum of 17 fps. These two were one of the mods that does heavy calculation, but I often am killed by a creeper or a zombie when I fluctuate from 0 to 3 fps. I have additionally turned everything in OptiFine off and have changed my render distance to Short +16.

Question

How can I reduce lag in Tekkit/Technic? Is it possible to remove some mods that I care less about, or is there an easier solution?

System Specs
System Specs, also listed below
Sony Vaio running Windows 7 Home Premium (64-bit) 6 Gigabytes of RAM, 3 given to the Technic Launcher
Intel Core i5 processor
Nvidia GPU (not sure what specs)
Java version 1.7.0_05 (32-bit since for some reason, x64 doesn't like me)

share|improve this question
    
switch to feed the beast –  ratchet freak Nov 16 '12 at 8:18
2  
@ratchetfreak: As I understand it, the most CPU-intensive mod in tekkit is BuildCraft, which is also included in that mod pack. Unfortunately, it's also the most awesome - Tekkit without quarries just wouldn't be Tekkit anymore, so simply disabling BuildCraft would ruin it. –  BlueRaja - Danny Pflughoeft Nov 16 '12 at 8:29
    
@Jeff: I've heard of some people having issues in Single Player but not on multiplayer (since then the server is doing most of the CPU-intensive work). Have you tried playing on a multiplayer server and just moving far, far away from spawn (so you don't get griefed)? –  BlueRaja - Danny Pflughoeft Nov 16 '12 at 8:32
2  
@BlueRaja-DannyPflughoeft yeah but in the FTBLauncher you can disable specific mods –  ratchet freak Nov 16 '12 at 8:37
1  

6 Answers 6

up vote 0 down vote accepted

If you are playing with a pack that includes ExtrabiomesXL, stay away from the redwood forests. The leaves of the redwood trees extend further from the trunk than vanilla Minecraft allows, meaning that upon entering the biome, hundreds of redwood sapling entities are created and dropped. While these can be great for early fuel, rendering all them absolutely kills your FPS.

Perhaps this is what caused your 2-3 FPS while killing (or being killed by) the wolf?

share|improve this answer

Maybe you should remove any additional mods that are not in the tekkit pack and switch to the default minecraft textures .this may ruin playing experience but a t least you still have tekkit.

share|improve this answer

By the looks of things your CPU isn't enough to handle tekkit. Mine has a turbo boost of 3.10 GHz, even with that I lag. If anything, turn your render distance to tiny but turn fog off. If you want to remove mods (this may ruin tekkit) get rid of the one that creates volcanoes and oil, more map generations are going to make your CPU work a lot harder.

share|improve this answer

If you are running Tekkit or Technic on Windows, set the priority to high in Task Manager. You will not be able to use other applications without lag, but at least Minecraft should work. I am not sure how to do this in a Mac, but if you can find the process, then try to change it so that it is the highest priority.

share|improve this answer
2  
You mean real-time priority under task manager? This could have horrible consequences. All other interrupts/scheduling could get delayed etc in favor of this one process. –  ヴァイシャリ Dec 7 '12 at 17:11
    
@Jeffrey did this solve it for you? –  ヴァイシャリ Dec 7 '12 at 17:13

Do you run any custom texture packs? I had the same issue attempting to run 256x Sphax BDCraft, Didn't matter what settings i ran Minecraft at; the framerate was somewhere between 0 and... well, 1.

Switch back to the default texture if you're using a custom one and see if there's an improvement. Then try installing a lower resolution one.

share|improve this answer

If anything, try disabling Matmos (no idea why it would lag, just that it's the only thing that's constantly running in the background), Smart Moving (again, no idea why it would lag, but I know it's running in the background), and potentially even Optifine. You could be running an Optifine build that isn't meant for your hardware which could cause the lagging. In my opinion, that's the most likely- even though by default Technic ships with Optifine Standard which is unlikely to cause that kind of effect.

Don't remove too many mods, especially from Tekkit- then you can't join any servers! And if you remove mods from Technic, maps you download from online may not function correctly.

share|improve this answer

protected by fredley Jul 25 '13 at 12:49

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.