Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Possible Duplicate:
360 controller battery doesn’t hold charge after unplugging Play & Charge Kit

My Xbox controller battery doesn't charge.

When I plug it in, the indicator light immediately goes from red to green.

Is their any solution for this?

share|improve this question
add comment

marked as duplicate by Sean, Bora, pixel, MBraedley, Jupotter Nov 17 '12 at 14:42

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

Have you tried the paperclip reset method?

These things usually break for two reasons.

  1. The battery is improperly conditioned.
  2. The Charging level indicator has failed.

Either way, this video has a solution for both.

It involves a series of pins to short using a paperclip.

share|improve this answer
    
It Worked!!! You sir, are a scholar. –  Herman Shine Nov 17 '12 at 5:38
    
Accepting his answer would be appreciated. –  Evil Closet Monkey Nov 17 '12 at 6:45
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.