Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

After the recent updates to the ICCup Launcher I no longer see the option to join the abys server option only the regular servers are displayed: west east asia and Europe.

Im doing everything the way I always did but the option does not show up.

I also tried searching for the solution elsewhere I've seen that other people are having similar problem in this post. I tried following the suggested solution of downloading the iCCup_WarCraft_3_Reg.zip file but it didnt help me at all.

share|improve this question
    
I already reinstalled the launcher, restarted computer and closed down all other programs including the launcher before trying to get the option back. This did not yield any results so please dont post it in the answer. –  Xitcod13 Nov 23 '12 at 9:35
add comment

2 Answers

up vote 2 down vote accepted
+300

Some research showed that other people had this problem as well.

Apparently, this is a bug that is caused by the current iteration of the ICCup launcher.

Unlike previous versions, the launcher no longer re-adds the registry entry for ICCup every time you start it. As a result, anytime you access a regular battle.net gateway (such as USEast) Blizzard removes the ICCup entry and you have to go back to ICCup.com and get the registry entry.

If you are interested in doing this manually, the following steps should suffice just know that anytime you manually edit your registry, there can be dire consequences if you do it wrong.

Manual Registry Edit:

  1. type 'regedit' into the start menu's 'Run' dialog or directly into the search for windows Vista and beyond.
  1. navigate to "HKEY_CURRENT_USER -> Software -> Battle.net -> Configuration"

  2. open the Battle.net Gateways key

  3. add the following lines to the bottom of the file then save and close it. (Note: the format is always gateway address, time difference and then server name.)

    sc.theabyss.ru

    0

    iCCup

Upon restart, you should have iCCup at the bottom again. However this change will revert anytime you connect to a Blizzard gateway.

credit to: sGs.DNH

The original, source of this, including another option in case this fix doesn't work can be found at:

http://www.iccup.com/community/thread/503519.html

share|improve this answer

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

    
Thanks for expanding your answer. I'd recommend removing the bit after the link, as going, "If this doesn't help, check there instead of here" runs counter to how Arqade works; we'd like authoritative answers provided here. –  Frank Nov 30 '12 at 16:59
    
Psst....we're not a forum! :P –  Frank Nov 30 '12 at 23:35
    
By the time I'm done, the list of edits will be longer than the post :P I promise I'll get the hang of this soon. –  superdemongob Nov 30 '12 at 23:42
    
No worries. :) But you also don't need the edit lines. If you want to expand your post, feel free to add in the steps found at that link. That'll help your answer. –  Frank Nov 30 '12 at 23:45
    
Finally something that works. Im wondering if you know how to make this solution more permanent every time i enter a gateway I need to go to regedit and redo the whole thing. I was trying to make the reg file read only but i cant even find it on my computer. –  Xitcod13 Nov 30 '12 at 23:50
show 8 more comments

I'd like to add that there are two ways to stop other servers from overwriting your server list in the registry.

  1. Modify your existing registry key
    • HKEY_CURRENT_USER\Software\Battle.net\Configuration\Battle.net gateways - Modify the first line and set it to a high number like 99999
  2. Create a new registry key to override the other one. Right click -> New -> Multi-String Value
    • name it "Override Battle.net gateways" and paste the server information from Battle.net gateways
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.