Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was trying to download a F2P steam game, which when I click the install button from the app page, launches the steam wizard to install it, however nothing actually happens after the wizard closes. It appears neither in the library or within the downloads.

This happens if I try from within the Steam client or my browser and launching the steam:// link

I have tried running Steam as a admin, I repaired Steam using the Steam installer, I repaired steam using the steamservice.exe /repair function, I tried renaming the ClientRegistry.blob file to have steam rebuild the file.

share|improve this question
Which game is it? – Wok Nov 18 '12 at 12:52
  1. Uninstall just the Games for Windows - LIVE client through the computer control panel.
  2. Reinstall just the Games for Windows - LIVE client from this link
  3. Reinstall Age of Empires Online from within the Games for Windows - LIVE client.
  4. Navigate to the directory where you installed the game and run the launcher.exe file as an administrator.

Reference: Steam forum.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.