Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I am trying to connect to my friends Hamachi server, but whenever I go to my sever selection, it says can not connect. Is there something I am doing wrong? I have been using his server for a while, and this just started happening. I can connect to my other servers, but that one is not working.

Here is his server.properties:

#Minecraft server properties
#Sun Dec 02 12:50:07 EST 2012
generator-settings=
allow-nether=true
level-name=world
enable-query=false
allow-flight=false
server-port=25565
level-type=DEFAULT
enable-rcon=false
level-seed=
server-ip=
max-build-height=256
spawn-npcs=true
white-list=false
spawn-animals=true
snooper-enabled=true
hardcore=true
texture-pack=
online-mode=true
pvp=true
difficulty=1
gamemode=0
max-players=20
spawn-monsters=true
view-distance=10
generate-structures=true
motd=A Minecraft Server
share|improve this question
6  
What version? There's a bug in 1.4.4 that makes LAN connections always fail. –  SevenSidedDie Nov 22 '12 at 2:57
1  
Sounds like SevenSidedDie might have found the issue, but (stupid question) are you using your friend's IP shown in Hamachi and not any other IP? His local IPv4 address as shown in ipconfig is not the same thing. –  Sadly Not Nov 22 '12 at 2:59
2  
@SevenSidedDie This is fixed in the 1.4.5 update. –  Andalur Nov 23 '12 at 14:07
2  
Did you make sure that Hamachi is the highest priority network adapter? –  Schism Dec 2 '12 at 18:07
1  
Does anything show in the server console on your friend's end when you try to connect? Maybe something along the lines of [INFO] /X.X.X.X lost connection? –  kuyan Dec 2 '12 at 22:25
show 10 more comments

4 Answers

Are you sure you're using the correct Hamachi IP?

On November 19th, all Hamachi IPs everywhere changed. The reason is that the 5.x.x.x IP-space, which Hamachi has always used because it was never in use anywhere else, began to be publicly routed (ie. used).

In a somewhat humorous twist, Hamachi decided to begin using the UK's Ministry of Defense's IP address space, 25.x.x.x, which was also recently in the news for having a block of 4-million IPs they're hoarding to themselves for internal use.

So, in short, all Hamachi IP's now begin with the number 25. Make sure the server you're connecting to does, too. And make sure neither you nor the server are running any software which blocks traffic from those IPs (such as PeerBlock!)

(Also, if the server-ip setting in server.properties is not blank, make sure it to set to the new IP as well. If it is blank, make sure the server has Hamachi set to the default network adapter; see my other answer)

share|improve this answer
add comment

If my other answer does not help, the most common problem with Hamachi is not having it set as the default adapter (this isn't always necessary; it seems to be hit-or-miss with some games).

Here is a guide for doing that in XP/Windows 2k. To do it in Vista/7:

  1. Go to start --> control panel --> Network and Internet --> View Network Status and Tasks --> Change Adapter Settings --> (hit 'alt') --> Advanced --> Advanced Settings.
  2. Click on "Hamachi," then click the up-arrow until Hamachi is at the top of the list.
  3. You may need to restart your computer afterwards. You usually shouldn't have to, but you may also need to undo this setting to use the internet like normal again :)

Make sure Hamachi is set to the default adapter on both the client and the server.


And finally, if none of this works, try using Tunngle instead. I've had much better luck with it than Hamachi in the past; unlike Hamachi, it's specifically designed for games.

share|improve this answer
1  
I did +1 this. Thanks a lot. BTW OT but I enjoyed reading your blog. :-) –  ヴァイシャリ Dec 7 '12 at 16:53
add comment

Uhm, it's quite obvious that the first mistake is server-ip=

The host need to put his hamachi ID here

share|improve this answer
add comment

You said that before it worked correctly so I am mostly sure the server.properties file reset because of the update as once happened to me also.

Your friend should need to do this things before you can join his hamachi network:

  1. Open Hamachi and go to Network > Create a new network

  2. Enter the new unique network ID and a password to create the network

  3. Right click the IP beside to the power button and select "Copy IPv4 Address"

  4. Go to server.properties file and paste the IPv4 Address beside to server-ip=

  5. Start server

What you should need to do to join his server:

  1. Open Hamachi and go to Network > Join existing network

  2. Fill the fields with your friends Network ID and password in order to join his network

  3. In this new network you joined right click your friend computer's and select "Copy address"

  4. In Minecraft use that IP to join his server.

share|improve this answer
add comment

protected by Community Jul 17 '13 at 21:11

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.