Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

The game runs without any problems other than all of the item menus (backpack, ammo/gun purchase, sell) all have their item icons mixed around so nothing I see is correct). For instance, it shows a blank item for my primary weapon and a random image of a pistol for my secondary, when in fact I have a different pistol and a sniper rifle equipped. Also, as I mouse over my backpack items, the pop up shows a totally different gun than the image in its place. It's frustrating as all hell, and even keeps me from being able to put the last item in my backpack in the bank. Anyone else see this?

I also had this issue in EVE Online, and the only thing I can think of is my main (OS) hard drive is named E:

  • Quad-core AMD 3.1ghz
  • ATI HD 4870 1GB
  • 4GB DDR3
  • Windows XP, SP3 fully updated

UPDATE: I reinstalled the game from Steam instead of from the CD from Newegg and the problem was gone. However, at level 14 my screen freezes with the sound on. I'm thinking my old ATI card is on the outs.

share|improve this question
6  
Sounds like your GPU is busted –  badp Nov 22 '12 at 21:42
3  
Can you provide screenshots? –  ayckoster Nov 23 '12 at 2:06
1  
Hm, I've gotten a scrolling bug where scrolling doesn't work right and might not be selecting the weapon that appears to be selected, but I haven't noticed it affecting equiped guns. A screenshot might help –  Prinny Brocka Nov 24 '12 at 0:31
add comment

1 Answer

Sounds like your graphics card is about to give way. Other possibilities would be your hard drive has some bad sectors, but you would most likely have problems out-of-game as well if that was the case.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.