Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have an HP Probook 4730s laptop with a ATI Radeon HD 7470M graphics card. It's the DDR5 version, running on Windows 7 SP1 64bit.

When gaming I get awful performance (10-20fps on ultra low settings, as can be expected of a laptop with entry-level GPU) but I recently noticed that I was running on the integrated Intel HD Graphics card.

I enabled graphics switching in the BIOS, disabled automatic switching in the Catalyst Control Center, and enabled High Performance Mode under all circumstances.

Using HWInfo and GPU-Z, I now see that when running a game (Arma 2 today) it indeed uses 100% of the ATI GPU. But it also shows that GPU running at 100Mhz, and GPU memory at 40.5Mhz. It occasionally peaks at 750Mhz (the advertised clock speed) for half a second or so, and then falls back to 100Mhz. Ingame performance is now even worse (5-10fps on ultra low settings) than when using the integrated GPU.

Could the ATI still be running in some power safe mode?

I've already tried installing ATI Tray Tools, but that Bluescreens when I run it. I also tried disabling the integrated graphics, but my BIOS won't allow me to do so, and when disabling it in Windows my screen just remains black. I have tried to install Riva Tuner, but I can't get that to do anything or report anything on my GPU. As I said, HWiNFO and GPU-Z both agree on the GPU and its utilization, but won't allow me to change any settings AFAIK.

The BIOS is patched, and ATI won't allow me to install the latest Catalyst Control Center. It complains that I don't have a compatible graphics card (presumably because it's HP branded). I already have the latest HP graphics drivers installed.

Any way to disable the power safe mode on the ATI card? Force it to run at higher speeds? Or maybe overclock it manually?

One thing I would like to try is using an external monitor. I've read somewhere that the main laptop screen always uses the integrated GPU (in line with my experience disabling that). Without an external monitor, there is no way to set the default screen in Windows, it just reports no screen attached to the ATI card.

Update 1 I have installed the http://leshcatlabs.net/ ATI drivers, which doubled the memory clock to 81Mhz! :-P Still awful performance ingame, and in my Catalyst Control Center I do have the Overdrive options now but they are all greyed out and also stuck at 100Mhz. Also ATI Tray Tool still Bluescreens even with the latest (although third-party packaged) ATI drivers.

The temperatures stay at 38-44C, and the clock speed does not fluctuate with temperature changes.

share|improve this question
1  
This is probably better on Superuser, I would suspect. –  Frank Nov 25 '12 at 1:49
1  
I used this method to install updated ATI drivers on my Toshiba laptop with a similar switchable graphics chip, and boy did it make a big difference. I'd give that a shot, personally –  agent86 Nov 25 '12 at 1:59
    
Yes, I was thinking about that, but since the FAQ listed gaming hardware specifically I thought I'd give it a chance here first. Feel free to move it is more appropriate there. –  Kamiel Wanrooij Nov 25 '12 at 2:00
1  
Have you watched the temps? IT's possible it has heat-throttling. Since Laptops have terrible cooling systems it's entirely possible it's getting throttled. Have to tried Furmark? You can watch a graph of your CPU's temp over time, watch for peaks then dips/plateaus and note if the clock speed drops during the flat part of the graph –  Ben Brocka Nov 25 '12 at 3:33
add comment

3 Answers 3

up vote 4 down vote accepted

After more long hours of searching I came across this.

Installing MSI Afterburner and raising the clock speeds with 1Mhz ended up fixing the problem for me!

Now I run that same Arma 2 at 50-70 FPS :D Thank you, David from 2011!

share|improve this answer
    
Ah ha, good find! I'll leave my answer in case anyone with heat throttling issues stumbles by –  Ben Brocka Nov 25 '12 at 15:33
add comment

I'm pretty sure your card's being throttled due to heat; most modern cards are smart enough to throttle to prevent damaging themselves in high-heat conditions, and laptops are notorious for inferior cooling.

You can verify that this is the problem using GPU Z: watch your clock rates and GPU temps. Stress test the GPU Furmark will do this easily, Furmark also includes GPU temp and clock speed info on it's own, but only for it's own benchmarks, not your games. You can test real-world performance via GPU Z.

I couldn't find an easy way to actually disable throttling; you can on CPUs, so it may be possible, but it's a really bad idea. Disabling throttling is worse than overclocking because generally overclocking is done while watching temps to make sure they're safe; it's generally the heat that kills/lowers the life of your equipment. If it's throttling, you already know it's hitting a fairly high (even if conservative) ceiling temperature, one AMD doesn't feel the card should operate at.

To try and solve the actual heat problem, try a laptop cooling pad. I honestly have no idea how well they work, surely nowhere near as well as a simple Desktop case fan, but it might drop your temps slightly.

If your card's overclocked (sounds like it isn't) step it back a bit; in the absence of proper cooling, Overclocking can actually worsen performance by bringing temps to throttling levels faster. This leads to sprints of high performance and more frequent throttling.

share|improve this answer
add comment

I am pretty sure you don't need to get too technical with your ATI Radeon graphics 7470m card. Truth is that it was primarily configured by HP to give you the best performance in regard to it's capabilities and so you don't need to change its bios or the laptop bios. Just right click and select configure switchable graphics options whenever you are playing high end games, then select the running application and set it to high performance. Then you will notice a very big difference in performance and stability. The ati Radeon 7470m may not give the very best but in gaming but atleast the usual low demanding games run well especially if you connect your laptop to a slightly bigger screen 32/42 inch via HDMI. I followed the sam steps on my HP Probook 4730s Sam graphics as yours with 8gb ram 640gb HDD core i5 2 generation processor laptop. Found out that FIFA13, Virtual tennis 4, Need for speed Hot pursuit(2010) games run very smoothly when high performance mode is selected.

Regards,

Robert

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.