Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

When I login in World of Warcraft, I just get the "Success!" message, when I click on "cancel" the realm selection screen comes up, but when I try to login on any realm I just get the message "Logging in to game server" and this don't changes even after a few minutes (most of the time sometimes I can login after a while). What should I do to fix this?

share|improve this question
    
You'll get better support if you go to the warcraft forums and post this specific question. If you're experiencing a problem that many users are also experiencing then you'll doubtless find posts of a similar nature (and hopefully with a "blue" response from a GM). If it's a problem specific to just you then you're also a lot more likely to get a useful answer. Now, all of that being said, when I've had this problem in the past it's usually because one of the many servers is down (the world server or the character server or the login/authentication server). –  Jagd Nov 27 '12 at 23:57
    
Is this beta, test or live? Which server? When did this start happening? You'd have to include a lot more details if you are to post this on Blizzard's website. –  deutschZuid Nov 28 '12 at 0:42
    
Most likely this is happening to you on a Tuesday, which after checking my calendar the day this was asked was in fact a Tuesday. Tuesday's are notoriously server maintenance days and WoW is typically down for at least 8 hours every Tuesday of every week. –  Ravekner Dec 11 '12 at 19:13

2 Answers 2

up vote 2 down vote accepted

If this happens often it could be a local problem, try reinstalling WoW or deleting your WTF folder. If not the server could be under maintenance or blizzard could be having some other problem before. I've had this problem before also and it usually goes away with time.

share|improve this answer
    
Deleting the WTF folder made it normal again, thank you. –  Andalur Nov 28 '12 at 16:57
    
I always find it funny that the WTF folder is usually the source of so many "WTF!?!?" moments with WoW. :) –  Jasarien Feb 26 '13 at 11:02

Try:

  1. Repair tool on patcher
  2. Deleting Battle.net files then repair tool (not sure if will just fuck up game though, seems to half the time)
  3. Reinstalling WoW

Remember: If you need to install do so after backing up all of your addons, or at least writing them down.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.