Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

In Minecraft, I have a graphical glitch where there are small purple and sometimes blue static squares all over my Minecraft screen. How could I fix this? They are roughly the size of the on-screen Minecraft blocks and they jitter left and right ect. and it makes it very hard to play.

Thank you!

share|improve this question

closed as unclear what you're asking by galacticninja, 5pike, Studoku, Mathias711, DavidYell May 28 at 11:08

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

Do you have a screenshot showng the problem? –  alexanderpas Oct 21 '10 at 11:40
Do you have an AMD card? –  DrFish Oct 21 '10 at 12:50
Do you experience this in other games too? Might be a hardware issue. –  Tom Wijsman Oct 23 '10 at 0:26
do you use a texturepack? if you do try using mcpather that will fix texture pack bugs –  RustyMembers Jan 11 '13 at 18:09

7 Answers 7

Since there's no option in Minecraft for purple jittery shapes, the best you can hope to do is update your system and hope that fixes it, or else wait for a new patch to Minecraft.

  1. Update Java
  2. Update your graphics drivers.
  3. Restart your computer

If it's still having problems after that, then delete Minecraft and re-download it, allowing it to re-download all its updates.

See BlueRaja's comment for another important step if you decide to "re-install" Minecraft.

share|improve this answer
Make sure to also delete your minecraft cache and settings folder: %APPDATA%\.minecraft –  BlueRaja - Danny Pflughoeft Oct 21 '10 at 14:26
Be aware that this will delete your worlds as well, so make sure to back them up (and put them back later when everything works okay again, hopefully) –  yatima2975 Oct 25 '10 at 10:05

I found out how to fix it on my computer. I changed my settings on my nVidia graphics card. There was a slider for performance vs. quality, I changed the options to "let 3D application decide" (the performance option had the same result) and the graphical problems went away. Hope this helps.

share|improve this answer
Worked for me (Tekkit, with Optifine.) Thanks. :) –  Li-aung Yip Jul 19 '12 at 7:39

It might be a texture problem, have you installed any alternate skins?

share|improve this answer

Not sure if this helps:

There are weird purple lines around every block of water in the game, so from a distance the water looks like a purple sea!

Disable forced anti-aliasing!


share|improve this answer
+1 Minecraft and Anti-Aliasing do not work nice together. –  Bobby Mar 15 '11 at 18:26

The new AMD 11.5 Driver does not work well with Minecraft. The problem stems from AMD Power Play which actively slows your GPU Clock speed down when not in use to conserve power and to lower heat. Now usually when entering a 3D game the clock speed is automatically adjusted to full allowing your game to take advantage of the GPUs full power. But in the case of 11.5 it does not and in some cases actually down clocks the GPU lower then it's original idle power play setting.

My recommendation would be to downgrade your AMD driver package back to 11.4 which is confirmed to be working.

share|improve this answer

The last time I saw artifacts like that it was caused by the graphics card overheating (this was for a different game, but the effects sound very similar)

You can try either reducing the graphics settings or ensuring that your graphics card / PC is well ventilated.

share|improve this answer

For nVidia GPU.

Default global settings for nVidia control panel have anti-aliasing overridden.

In nVidia control panel - "program settings" find or add minecraft,

Find "anti-aliasing - mode" and set this to "application controlled"

Other cards will be different, but anti-aliasing is the cause of these glitches.

share|improve this answer