Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

First of all, before jumping here to pop a question, I've been all over the Net trying to find a solution to the problem.

Apparently, loads of people were having a problem with sound in this game, most if not all managed to solve it by either setting DeviceName=Generic Hardware or leaving DeviceName value blank so the game would detect the sound device during each start up. Also, by setting max channels to 64 or higher depending on sound card capabilities.

Now, I've tried using an array of different settings and no matter what, I always have a popping sound repeating every few seconds.

I'm running the game on Windows 7 and have X-Fi XtremeMusic sound card capable of processing up to 128 sound sources when in Game Mode. Here's the tricky part. When using Entertainment Mode, the popping sound is gone, but the maximum amount of processed channels can't be set higher than 64, no matter what game settings I use. Which is natural as Entertainment Mode only works with up to 64.

I can definitely play in Entertainment Mode, but the sound is not as good in this mode as in Game Mode (juding by a vast experience I had with loads of other games which like Game Mode fine, just as they should).

I find it weird that the games designed for X-Fi cards (says so on the back of the box) can't really support one...

My question is, is it possible to run Mass Effect using X-Fi Game Mode and having 128 sound channels and not having the horrible popping sound?

share|improve this question
    
This forum post suggests that if you are trying to use 128 sound channels, then setting the line TotalAvailableChannels=126 in the configuration file (yes that's 6, not 8) would ease your sound issues, and that disabling Hardware Acceleration for audio would help as well, in addition to setting the total available sound channels. –  kalina Dec 4 '12 at 8:37
    
Your PCI subsystem must be weak to transport 128 channels at one. 64 channels will be fine. You will never hear more than 64 sounds at a time, anyway. –  DrFish Dec 4 '12 at 8:46
    
@pixel I already mentioned that I tried a whole bunch of various configuration settings. One of the best was to use "DeviceName=" (empty value) and erase all the channel-related settings. This way, during every start-up, the game will detect the sound device and all the available channels. I see from the log that I get 126 or 125 channels. It doesn't make any difference. Interestingly enough, even if I set 64 channels with Game Mode, the popping is still present. So it's not about the channels directly. –  NeverwinterMoon Dec 4 '12 at 9:39
    
@Bora I already stated that I have no problem whatsoever with any other games using Game Mode and 128 channels. It's not hardware limitation. I also stated that I can clearly hear the difference in sound between Game Mode and Entertainment Mode. Not sure I could hear difference between 64 and 128 channels, but there are some other difference between those two modes. The difference is very noticeable, indeed. –  NeverwinterMoon Dec 4 '12 at 9:41
    
The popping could be buffer underruns, I imagine one of the major differences using 'game mode' causes is a smaller buffer (and thus lower latency on audio), no proof on this without looking into it further though. –  kalina Dec 4 '12 at 9:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.