Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I've been playing don't starve for a while, and with the last update they added a bloom effect which is a huge decrease in my performance, when near fires my computer drops to 30 FPS or less.

There is an option to toggle it, but turning it off then clicking "Apply" makes my monitor go dark, then when it gets back to normal my desktop icons are scattered as if the resolution was made lower, then higher again. I should also point out that dont starve starts at a huge resolution which goes off my screen, trying to change it in the options doesn't work but resizing the window does.

I tried changing the options in the .ini file but there's no bloom option there, and changing the resolution values has no effect whatsoever.

What can I do to disable the bloom effect and the bad window resolution on start-up?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

A friend of mine had the same exact problem. Set the game to full screen (at a good resolution setting) and change the settings. It seems that when you click "Apply" the game cycles modes, which crashes on some systems.

share|improve this answer
    
Thanks a ton, I was losing hope of getting this answered, i'll try it today. –  Bugster Dec 13 '12 at 6:09
    
I might add, the game doesn't always scale cursor controls correctly. (Similar to changing resolution in valve games). –  Nathan Goings Dec 14 '12 at 7:37
add comment

Go to \Documents\Klei\DoNotStarve and delete the file called settings.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.