Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Im trying to connect my PS Vita to internet with my router, but Im having lot of trouble. The connection to the router seems to work ok, but internet is not working. When I run the "Internet Connection Test", I get this:

Obtain IP Address    Successful

Internet Connection  Successful

PSN Sign-in          Failed

Error code : c2-11003-5

The WWW Browser doesnt work either. What am I missing? My Android phone, my laptop and all the other devices Ive connected to the router worked alright out of the box.

share|improve this question
1  
Do you get an error code? –  Krazer Dec 13 '12 at 20:54
    
Yes, Ive updated the question –  Dbugger Dec 13 '12 at 20:59
    
did you try updating the machine? that might work, otherwise try checking your psn password etc. –  Stefto Dec 14 '12 at 0:04
    
its not just the PSN password. the WWW browser doesnt work either –  Dbugger Dec 14 '12 at 0:28
    
I found this thread in a support forum: community.us.playstation.com/t5/Support-General/…, it's about a PS3, do you have any other sony devices (like a PS3) that connect to PSN? –  Shykin Dec 14 '12 at 1:37

3 Answers 3

up vote 1 down vote accepted

I've looked around and found some people who had similar issues. The support officer suggests turning off the 'Disconnect Wi-Fi Connection Automatically' setting under WiFi settings.

Link to support post: http://community.eu.playstation.com/t5/PlayStation-Vita-Technical-Help/C2-11003-5/m-p/17735396

If this doesn't work then honestly you can only do a few things:

  1. Try to connect to PSN using another sony product like a PS3. Just going to the website wouldn't be as effective but is worth a shot to see if you can log into PSN from your browser. (In case it's blocked for some reason)

  2. Try changing the router settings such as allowing the ports PSN requires, disabling firewalls (Only temporarily, to see if it's the cause), enabling PNP and check for other security settings. If you can't get into your router, try basic stuff like Admin/pass or Administrator/password, you might get lucky otherwise, you need the password

  3. Try connecting off of another router. This might be hard to do but try to connect to PSN off of another network or router. Go to some place with free wifi and try connecting through there. If you still can't connect then it's a setting on your vita

  4. When all else fails, contact their technical support. Yeah they're gonna run you through what I said but they may know something I don't.

The error is a general network error and it's hard to track down the exact cause. So trying a lot of solutions and trying to narrow it down is really the only way to go at it.

share|improve this answer
    
That didnt work :( on or off, result is the same –  Dbugger Dec 13 '12 at 21:19
    
The error code means it's a general network error, can you give anymore information? Whats your technical experience with routers so I know how to frame my answers. –  Shykin Dec 13 '12 at 21:34
    
I know about opening ports, if thats what you mean. Unfortunately my ISP didnt give me the password to the 192.168.1.1 control panel, so I cant really operate the router. I hope the solution doesnt pass through there –  Dbugger Dec 13 '12 at 21:36
    
Unfortunately it likely may, what is your ISP and what kind of router did they give you? (I have comcast and they gave me their "Comcast router"). I'm betting it may have to do with your router settings not allowing something especially if you can't get into it. Their default settings can often be too secure in certain areas and not secure enough in others. –  Shykin Dec 13 '12 at 21:43
    
My ISP is Telefonica (Movistar) and the router is a Zyxel p-660HW-D1 –  Dbugger Dec 13 '12 at 21:47

I've had the same problem and tried all sorts, setting up DMZ, enabling uPNP, switching off firewalls... all to no avail. Bizarrely I could connect to the internet fine and i could connect to PSN using next door's wifi. The solution for me was dead simple...

On the vita, in: settings>network>Wifi settings; the second from last option "Disconnect WiFi connection automatically" needs to be ticked. Makes no sense to me but it worked.

share|improve this answer
    
Indeed that was the solution. No idea why either. –  Dbugger Feb 8 '13 at 11:48

Just uncheck the "use wifi in power save mode" option. :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.