Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Alright this is just baffling me. I have never had performance issues on my Desktop unless its just an easy Driver Update. The worst part is that my Laptop has no issues playing Far Cry 3.

My Desktop consists of:

  • Windows 7 64 bit
  • Intel Core i7 2700K Sandy Bridge
  • ASUS P8Z68-V GEN3 Mainboard
  • 2x DDR3 4MB PC3-12800 (Mushkin 992057 (997057))
  • 2x AMD Radeon HD 6900 Series (Crossfire)
  • and a few hard drives.

If listing my laptop hardware would help I will.

I've downloaded AMD's new Driver Update that is specific too Far Cry 3, still didn't help. Downloaded AMD's Beta Driver Update still didn't help, did both updates at once, nothing. Right now I have all three of the current AMD Driver Updates, still low FPS. I even had to lowered my graphics to low (cringe) and my FPS is unchanged.

I've also checked for Windows 7 updates.

After trying for a few hours I decided that I would just suck it up and only use my laptop for playing Far Cry 3. Until today, I saw they released a patch that specifically mentions above 32 core computers, but nothing has changed for me.

I am beyond frustrated with this and would love some in-site. What else is there to do to increase performance while playing Far Cry 3?

share|improve this question
    
couple thoughts : "low" graphic settings unload processing from the GPU to the CPU meaning you're unnecessarily burdening your cpu in this case. Beyond that - suspect issues would be : Probably not really optimized for Xfire. Back when SLI was still "new and exciting" there were simply not very many games or HAL (directx) components that made proper use of these. However its 2012 so really its this : FarCry 3 is also available on consoles. Probably (likely) it is optimized for that market and PCs "can wait" –  Brandt Solovij Dec 14 '12 at 5:40
    
@BrandtSolovij ""low" graphic settings unload processing from the GPU to the CPU" What graphic settings are affected by this? Also, do you have a source for that (so I could read more about it)? All of my graphics settings are above low, except 'Geometry'. If it's at low I get more FPS, ranging from 5-10 FPS. –  galacticninja Dec 14 '12 at 8:03
    
@BrandtSolovij i will say that xfire has caused me more problems than its fixed –  Paralytic Dec 14 '12 at 12:54

1 Answer 1

up vote 2 down vote accepted

Try disabling crossfire. Many games do not play nice with multi GPU setups. I have a 2GB 6950 and the game runs fine for me.

share|improve this answer
    
ill give it a try –  Paralytic Dec 14 '12 at 12:52
    
Please mark your question as answered if it worked. –  atripathi Dec 17 '12 at 10:37
1  
in due time my dear watson, in due time. –  Paralytic Dec 17 '12 at 13:59
    
alright so i tried this out, it definately makes a huge difference. doesnt entirely fix the issue entirely, but the 6900 radeons arent very good by themselves so i think its just that. –  Paralytic Dec 21 '12 at 17:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.