Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Title: Tons of visual glitches
Version: 7.2.6 | 1.2.5 (Rec)
OS: Windows 7 x64 Professional (java's website says it's Win7 version 6.1)
Java Version: Java SE 7 Update 09

Description of Problem:
So my factory works 100% fine. It's all just visual. I've tried:

  • Completely deleting %appdata/.techniclauncher
  • Copying the save and saving it as main - copy (worked for a few hours)

It all looks like this:

Notice the hitbox is not there and the two chests that are connected to the pipe (the pipe is bending the right way) yet they appear to be way further back.

Image two:

Same thing, showing the chest hitbox. The chests still work, I can right-click them etc...

Image three:

The hitbox is a redstone engine. The particle effects are still there and it functions right, but it's not there...

Image four:

This is me standing in the redstone engines that are glitched about ten blocks to the left and about 3 forward. They're not solid. Also only the top 5th of the chest is showing.

Image five:

That's a crystal chest.

14: Emerald
11: Ruby
1: Sapphire
34: Silver ingot

Any ides why it does this?

Also I have a ruby, emeralds, sapphires and silver ingots in other chests and it doesn't glitch out.

share|improve this question
Have you tried deleting the install (after backing up your worlds) and having the launcher reinstall Technic? – SevenSidedDie Dec 24 '12 at 6:44
Multiple times. – Frank Dec 24 '12 at 8:14
You are using the normal texture pack, right? – Jeffrey Lin Dec 24 '12 at 13:53
@JeffreyLin Yeah, I am. – Frank Dec 24 '12 at 20:02
This sounds like it could be a graphical bug as opposed to a Java problem. What graphics chipset are you using, and is the driver up to date? – MTCoster Jan 30 '13 at 16:41
up vote 1 down vote accepted

I eventually found out that too many crystal chests can cause this.

I just replaced them with diamond chests, relogged and problem is fixed.

share|improve this answer

Most likely, one of two things happened:

A. You did not install TechnicPack correctly. Try re-installing it and making sure you are following the directions exactly.

B. This is a glitch in TechinicPack. Maybe TechnicPack isn't updated or it's a simple bug.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.