Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I play Civ 5 on my primary monitor full-screened. However, when I do this, my second monitor is always simply black. I can't use it for anything. Typically, I keep some things on my second monitor - chat/IM windows, a browser with my email and various social networks open, and similar things. However, with the monitor being black, I can't actually use anything there.

I tried playing windowed mode in Civ 5, but there was another problem there. When I left Civ 5 by clicking on another window, part of the game window goes behind Windows 7's start menu/task bar. In some dialog windows, some options are hidden behind the task bar. Clicking on the game doesn't bring it forward for some reason (most applications will move back in front of the start bar).

If there's any confusion about what I'm looking for, I'm looking for something similar to how games like Guild Wars 2 and Star Trek Online work. They are full-screen on one monitor, but my second monitor is visible and I can move my mouse outside of the game to give another window focus, and then back into the game to interact with that window.

Is there some kind of way for me to full screen Civ 5 on one monitor and have my second monitor usable? Some combination of settings that I haven't seen or tried? Are there any bugs in the Civ 5 support forums with workarounds that I may have missed?

share|improve this question
1  
Are you sure that's full screen and not borderless window mode? –  Raven Dreamer Jan 6 '13 at 17:03
1  
@RavenDreamer The full screen option is checked. There are only two options that I see - full screen (mark is checked) and window mode (mark is not checked). –  Thomas Owens Jan 6 '13 at 17:06
1  
I meant for Guild Wars 2 and STO. What you're describing sounds like borderless window mode. –  Raven Dreamer Jan 6 '13 at 17:07
    
@RavenDreamer It might be. GW1 might have been window mode and GW2 and STO may be borderless window mode. Either way, they don't have the problem that Civ has when in this mode - when I return to the game, the part game interface that is below the task bar come back in front of it so I have a full working interface instead of part of it being obscured. –  Thomas Owens Jan 6 '13 at 17:10
    
Not much of a solution, but you could set the start bar to auto-hide. –  George Duckett Jan 6 '13 at 18:57

7 Answers 7

up vote 5 down vote accepted

From searching Google it seems to be a problem for a number of people, and no one has any real fixes.

A few options you have: (while running in windowed mode)

  • Press Ctrl-Shift-Esc bring up the task manager go to the Applications Tab, Right click on Civilization 5 and select Bring to Front. When you click back on the game again it should be over the task bar.
  • As mentioned in a comment, set task bar to auto-hide.
  • Run the game in windowed mode at a slightly lower resolution. This will resize everything so you can always see it.

I just do the Bring to Front option as it puts it all back and seems to only have to be done once per game run.

share|improve this answer
    
I found people talking about the problem with no solution. I was hoping that I missed one. Perhaps they'll patch it at some point, otherwise, I'll just experiment with these different workarounds to see which one is the best for me. –  Thomas Owens Jan 7 '13 at 15:30
    
One thing to note with windowed mode: sometimes the screen edge won't recognize scrolling properly and you'll have to move by dragging. Which can cause unintended side effects like accidentally dragging the window to the bottom of the screen because you're dragging the title bar instead of the game. –  Nate Kerkhofs Aug 21 at 15:14

Try changing to Windows 7 Basic in Control Panel - Personalization. I was only able to to interact with Windows Desktop on other monitors during Civ V fullscreen using this setting. You have to change the option Bind mouse to Never in Interface Options i Civ 5.

Edit 1: I have tested some more as I have similar problem as you. If i enable full screen my two other monitors turns black, and i have to Alt+tab to get to the desktop. I think the problem lies with a feature called Desktop Composition. When enabling Windows 7 Basic theme you disable this feature. Only disabling this feature makes Civ 5 full screen and multiple monitors work for me. You can disable it in Control Panel - System - Advanced System Setting - Settings (Performance). I still have some issues when windows appear on primary monitor where Civ 5 is. I have to fetch it my clicking several times somehow, and sometimes the screens will flash black. But at least it works.

As for your specific problem i Civ 5 window mode, it seems you can just move your start menu to the other monitor.

Edit 2: Quick google on Civ 5 and desktop composition leads to http://forums.civfanatics.com/showthread.php?t=436775 which tells you can disable it on the Civ 5 exe-file in the steamfolder. This will at least turn it off when launching Civ 5 and re-enable it when game is closed.

share|improve this answer

It works with my setup (HP Pavilion Dv7 with an external 24 inch monitor) I play the game in the window mode on the 24 inch monitor and am able to use the other monitor at the same time. Occasionally I have the problem you have with the start menu being on top once in a while and that usually takes a game restart to fix the problem. The only time it does it, (not every time) is when I minimize the game window do something else on the 24 inch and them maximize the game window back.

share|improve this answer
    
I'll have to try again to see how frequently the start menu covers the game. It happened twice, and that was enough for me to turn fullscreen back on. Still, it probably wouldn't be good in multiplayer if that happens and a restart is required. –  Thomas Owens Jan 6 '13 at 19:42

Not an answer but a possible workaround. Try to enable "Auto-hide the taskbar" option when playing Civ 5 and maybe place it on top of the desktop (or left/right/whatever area you are less likely to hover over accidentally while playing) vs. bottom. It will dock and hide and your "taskbar above game window" issue might dissapear.

share|improve this answer

I have a similar configuration: a laptop with a small screen and an external large monitor.

  1. Before playing, swap primary monitors so that the bigger one was primary. (in Windows7, it is RightClick, "Screen Resolution", click the icon of the bigger display, check "Make this my main display", press "OK")

  2. When Civ becomes hidden behind the Start Menu, simply press Win+D twice. By first pressing, it will show the Desktop. Pressing it second time will then restore the original layout of windows, magically fixing all layout problems.

share|improve this answer

Hey I've got a little trick for this.. I wish I could do more for ya. I got a GTX 580. Anyways, the trick is this, you have netflix or media player running in the other screen full screen, and you load up civ 5.

  1. Press Escape to skip the bootup video
  2. While it is in the pre load screen (the screen before you the "press continue" screen with the guys head), alt-tab out to the movie window, and then quickly click back on the preload screen. If you do it right, you'll still see the movie in the second screen.

The catch is if you do anything else, or tab out, you lose it. But you can watch movies while you play this way.

I hope this helps and I hope they fix this sill issue.

share|improve this answer

I make it work with switching VLC to OpenGL and Civ V to windowed mode (video options, unclick "full screen") Good luck.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.