Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Just installed Fallout New Vegas.

After some time of game play the game just quit to Desktop without any error messages. Can someone point me directions on why this is happening and how can I fix it?

Running on Windows 7 32-bit, nVidia GTS250 MB.

share|improve this question
add comment

3 Answers 3

The game is very buggy, make sure you have the latest patch installed (should happen automatically if Steam is not in offline mode). Also try to install the latest Nvidia driver.

But most likely you just have to wait for a new patch to fix some more of the numerous crashing bugs this game obviously has.

share|improve this answer
add comment

If you have a multi-core machine, you may want to try these instructions: http://www.pdsys.org/blog/post/2009/02/07/Fallout-3-VideoDisplay-Freezes-sound-keeps-going.aspx

Please Note: Even though this was written with Fallout 3 in mind, it also works for Fallout New Vegas. Enjoy!

The game engine has some issues with processors that have more than 2 cores. You can force the game to only use two of them and it will stop the freezing. I haven't had it freeze once since I did this several days ago.

Open up the fallout.ini file in: My Documents\My Games\Fallout3

(Note: In Fallout New Vegas, Most tweaks which would normally go in the Fallout.ini file in Fallout 3 actually need to be made in the Fallout_default.ini file found under the \Program Files (x86)\Steam\steamapps\common\fallout new vegas directory in Fallout: New Vegas. This is because when the game is launched via Steam, it opens the launcher first, which overwrites your Fallout.ini file with the contents of the Fallout_default.ini file, along with your launcher settings. Make a backup of Fallout_default.ini, then edit it with a text editor.) (Source)

Find the line:

bUseThreadedAI=0

change it to:

bUseThreadedAI=1

Add another line after it and insert:

iNumHWThreads=2

This will limit the game to 2 cores and prevent the engine bug from causing the game to freeze.

share|improve this answer
add comment

From the PC Gaming Wiki's "Fallout New Vegas - Game Crashes Randomly" article:

D3D9.dll Replacement

Random Crashes (Random Crashes that tell you FalloutNV.exe has stopped working.)

I have personally tried NV Stutter Remover and CASM. NV Stutter Remover modifies the game to be more "stable" (more info on its New Vegas Nexus page here). CASM (Cipscis' Automatic Save Manager) allows for an incremental auto-save function specified by a time preset (can also be done manually through a hotkey), allowing you to load a savegame close to when FNV crashed. Fake Fullscreen Mode Windowed runs the game in windowed mode, which some report as helpful in preventing crashes (more info in its New Vegas Nexus page here).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.