I just found there's a handful of free DLCs for Mass Effect 3, including an Extended Cut that supposedly fixes some issues with the ending. So, of course I downloaded and installed them as soon as I could. However, after the DLCs were installed, the game would not load.

It would get past the opening credits, and the "Press START button" screen. But, at the main menu, it would then hang with a message that says "Checking downloadable content". The menu would still be animated, and the Loading icon would still be spinning. But I could let it sit forever like that and still not get a response. The only thing I could do is access the PlayStation menu and exit the game.

What causes this? Is there a patch or workaround?

4 Answers 4


I did some online searching, and got some information. It seems this problem is universal across all platforms. I still haven't found a definite cause for this problem, (though some are generally blaming crappy game/DRM design) or any statement from BioWare, but the community has come up with a few workarounds. I've had success with two, and haven't really bothered with the third. But there are some claims of the third being fairly reliable.

  1. (Maybe console-specific, or PS3-only.) Disable auto sign-on to the console's multiplayer network (e.g.: PSN, Xbox Live) and reboot. Or, just log off of the network before starting the game every time. If multiplayer functionality is desired, use the in-game menu to sign in to EA's servers and this should automatically prompt you to sign into your console's network also. This has worked well for me. I suppose the PC analogue would be to turn off Wi-Fi or unplug the network cable.

  2. Enable auto sign-on to EA's servers within the game. (You may have to try options 1 or 3 first, to get into the game menu needed to tweak this option.) This has also worked for me, and comes with the added benefit that you can re-enable your console's auto sign-on function as well.

  3. Wait approximately 30 seconds at the "Press START button" screen. Some users have reported good results with this. Since options 1 and 2 are working fine for me, I haven't personally tested it.

  • 1
    None of this worked for me... I've been having this issue for at least 4 months and the fact that I can't play multiplayer really sucks.
    – user55889
    Sep 24, 2013 at 14:48

If Origin is updating any of your games and you try and play ME3, you will get the Checking Downloadable Content endless loop. Pause any game updates and launch ME3, then you can resume your Origin downloads once you start the game (actually start playing - ie, past the main menu)


On the PC version, in Origin, I repaired the game (right-click, Repair Install), and then hit Show Game Details to list the DLC. Then for each one that is installed, I did Repair Install.

That did the trick for me.


For PC version: I got the game working in Origin > Game Details > [Actions] Game Properties > [x] Disable Origin in Game for this game > OK.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .