Apparently today I made a huge mistake: I sold my Mass Effect games for Xbox360 to buy the digital trilogy for PC (I'm relocating and wanted to bring Shepard with me in the journey, just in case of sudden Reapers).

Over this weekend I tried one torrent for each game, to see if they would work and they did. Today, after the purchase and download of the first game, the horrible happened: no sign of life whatsoever from the game. I can't debug anyhow, since Origin Client traps (and suppresses, I suppose) all warnings coming from the game. Tried both online and offline mode, with cloud storage enabled/disabled, with in game client enabled/disabled, compatibility mode with XP Service Pack 3, lower details and lower resolution from the game configuration. Nothing seems to work.

My laptop specification is:

  • Intel Core i7
  • 6gb ddr3 ram,
  • full hd screen
  • Nvidia Geforce GT555m

It can run most games at high details (Dishonored, Battlefield 3, Starcraft 2:WoL and HoTS Beta, Diablo 3 just to name some...) and the pirate version of the trilogy too (they launched, at least, didn't check for ME3 and 2 gameplay). The game is fully patched, with Pinnacle Station and Bring down the Sky DLCs installed.

What can this possibly be? Is it related to the Origin Client or some sort of compatibility issue of the game?


I stumbled upon some info from this link in TR forums and none of the solutions provided worked so far :(


Downloaded both patches 1.01a and 1.02, launched them and got the error "Can't find any installation of Mass Effect" just before they crashed. I then copied those patches files inside ME folder, ran them again with the same outcome (error + crash). Then launched the game and it works. I'd still like to know why it doesn't work, can't possibly consider this as "fixed" :|

  • have you tried running the MassEffectLauncher.exe file from your Mass Effect install folder and setting your game options or launching the game directly from that or was that removed from the trilogy?
    – Callum
    Commented Jan 18, 2013 at 21:00
  • my guess would be an optimus issue
    – l I
    Commented Jan 18, 2013 at 21:21
  • @Callum yes I did that too, the folder is still there Commented Jan 20, 2013 at 22:50

2 Answers 2


I got it to work by quitting Origin, then launching the Origin executable as administrator and launching Mass Effect from it. After that, Mass Effect would launch normally from Origin or its executable regardless of Administrator rights on Origin's execution

  • This worked for me! I need to remember to try this more often, because older games tend not to be designed with Windows 7's security features in mind, so you need full administrator privileges to make them work. Commented May 27, 2013 at 2:58

Had the same problem.

I created a desktop icon for mass effect.

Right click > properties > compatibility mode for windows xp (service pack 3) and then launch from the icon.

Seemed to work for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .