Is there a way to remove or automatically skip the following dialog, which I get because I have steam set to start in offline mode:

Steam is currently set to be in Offline Mode. Many features, such as Friends and the Server Browser, will not be available while offline.

[Go Online] [Start In Offline Mode]

  • I guess the only way is to go online :/
    – giskou
    Commented Jan 27, 2013 at 11:38

5 Answers 5


Just add (or edit if it is there) "SkipOfflineModeWarning" "1" to Steam\config\loginusers.vdf. Should work on Mac too.

Example content of loginusers.vdf:

    "<your profile number>"
        "AccountName"       "<your login>"
        "PersonaName"       "<your display name>"
        "RememberPassword"      "1"
        "Timestamp"     "<timestamp>"
        "WantsOfflineMode"      "1"
        "SkipOfflineModeWarning"        "1"

I wrote a script for Windows to automate it.

  • Thanks, sounds promising! But that doesn't work on Mac, at least when I add it like this: pastebin.com/QLuuj7sF . Is that the right place?
    – tog22
    Commented Sep 21, 2014 at 22:33
  • It looks like content of Steam\config\config.vdf file, not Steam\config\loginusers.vdf. Commented Sep 22, 2014 at 0:11
  • 1
    D'oh. My bad. Mac users, the file is at ~/Library/Application Support/Steam/config/loginusers.vdf
    – tog22
    Commented Sep 22, 2014 at 15:14

The Theory

While there is no official way of starting Steam in Offline mode w/o showing the pop-up window you mention in your question, you might observe that when you switch Steam client from Online to Offline mode, you get no such pop-up.

The reason why this happens is because Steam changes one registry entry that suppress displaying of that window. You can check it by yourself by downloading program called Process Monitor from Microsoft website and setting it to monitor registry operations of steam.exe while you switch to offline mode.

Only problem is that this registry value (SkipStayOfflineDialog in HKCU\Software\Valve\Steam) is reset to default when you exit the steam, resulting in displaying this "Please go online" dialog next time you start Steam application.


I came up with small batch file as a workaround for problems mentioned above. It's simple two code line file that first changes value of registry entry responsible for skipping offline dialog and then starts steam client:

@reg add HKCU\Software\Valve\Steam /v SkipStayOfflineDialog /t REG_DWORD /d 0 /f >nul
@start steam.exe

Just save this as a SteamOffline.bat (name of file is unimportant, only extension is) and place it in your Steam directory.

You can then use it for launching Steam.

You could also make a shortcut for this .bat and add custom icon for it, so you could pin it to Start Menu or place it on desktop. You could also set shortcut to run minimized if you don't want a cmd.exe window popping up in the middle of the screen:

enter image description here

  • In would be a good idea to go online once in a while to fetch new Steam and game updates;
  • You are modifying a registry with this file, if that statement scares you, then please do not use this method :)
  • You can add -silent after steam.exe in bat file to hide the "Connecting Steam account: Username" window;
  • You can always start Steam normally by executing Steam.exe or it's default shortcut.
  • That'd be great, except I need a Mac solution. Def deserves an upvote though!
    – tog22
    Commented Feb 17, 2013 at 23:26
  • Just wondering, is it not enough to edit the registry once?
    – raven
    Commented Mar 29, 2013 at 10:53
  • 1
    No, it is not. Steam changes again the values. Damn.
    – raven
    Commented Mar 29, 2013 at 10:54

Sorry, there is no way to remove that pop-up. You could go online or play in offline mode.

  • You are almost at 1337 rep. Just sayin' :D
    – Anto
    Commented Feb 1, 2013 at 10:38
  • @Anto :D EPIC!!!
    – MerajA
    Commented Feb 1, 2013 at 10:43
  • It would definitely deserve some badge or something !
    – Anto
    Commented Feb 1, 2013 at 10:45

There is no way to remove that.

Steam is a online program and can be played offline however steam keeps on recommending to play it Online.

Steam requires internet to keep your steam profile up-to-date as well as your games patched up. That's why steam wants to remind you that your in offline mode cause your steam cannot be updated.

However you must log into (or connect to) Steam every 30 days for authentication or your software will refuse to work properly (if at all).

You'll have to ignore it or go back to Online Mode.


I used Piotr Kowalski solution, which worked. However, it reset as Barthez (and galacticninja) said it would.

Rather than using the batch file to change the registry, I simply changed the loginusers.vdf to a read only file (Right click on the file, choose properties, check the Read-only check box.)

It works fine, but you will have to remember to uncheck the Read-only check box if you want to change to online or change other settings in the file.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .