42

Every time I boot into OSX or Windows, Steam automatically starts.

Is there a way to stop Steam starting whenever I boot up my computer?

  • Have you tried unchecking "Run Steam when my computer starts." under the Interface tab in your Steam Preferences? – Krazer Jan 28 '13 at 11:49
  • 1
    This is confusing, do you want Steam to not download stuff automatically or to not start on every boot? – kotekzot Jan 28 '13 at 12:06
  • 1
    @kotekzot Not start on every boot – Michel Jan 29 '13 at 18:01
  • 2
    for me setting steam prefs didn't help so issue open /Users/yourname/Library/LaunchAgents command and remove valve related plist file. – zsitro May 2 '16 at 8:26
  • 3
    FOUND IT: tekrevue.com/tip/stop-apps-launching-mac I would have posted a correct answer, but I don't have enough points. (none of the other answers will work on MacOS) – timothymarois Aug 7 '18 at 12:01
63

This can be done from within the Steam client

There is an option within Steam that toggles whether or not Steam starts with your computer. To change it, open up the main Steam window and select 'Preferences' from the 'Steam' menu, followed by selecting the 'Interface' tab, which brings up the following screen;

enter image description here

Simply uncheck 'Run Steam when my computer starts' to prevent Steam from starting with your computer. (Obviously if you wanted to Steam to start with your PC, you'd check this box instead of unchecking it!)

macOS

If, on macOS, this doesn't work for you, check for Steam in "System Preferences" > "Users & Groups" > [Your user] > "Login Items", and remove it via the '-' sign.

macOS login items

  • 7
    Does not work for OSX sadly. PS: Greetings from the vault! :P – TrudleR Apr 3 '18 at 20:52
  • 2
    Does not work in macOS – timothymarois Aug 7 '18 at 11:55
  • 6
    If unchecking the setting in Steam doesn't work for you on macOS you should check for Steam in "System Preferences" > "Users & Groups" > [Your user] > "Login Items". – Evil Oatmeal Oct 14 '18 at 10:52
  • 1
    @EvilOatmeal I added this suggestion as an edit. – opyate Dec 12 '18 at 14:17
10

An alternative solution on Windows (starting from 8) is to open task manager and disable Steam Client Bootstrapper from the Start-up tab.

Task Manager, Start-up, Steam Client Bootstrapper, Dropdown menu, Disable

Note: This is an override switch to Steam's setting. You cannot re-enable it from Steam settings after disabling it here.

4

In Windows 7 click the Start menu and type msconfig in the Search box. In the System Configuration program that opens, click the Startup tab, and then uncheck Steam. This does pretty much same thing as the Windows 8 tip.

  • The usage of pictures are great. but +1 anyway – Michel Sep 17 '13 at 11:09
4

OSX = open steam then next to apple icon in top left corner steam > preferences > interface then uncheck - 'run steam when my computer starts'

  • 8
    This seems like the right answer but Steam is starting at login on mine and this box is not checked. I've also confirmed it's not set to "Open at Login" in the dock. I'm going to try checking this box, clicking OK, and then unchecking it again to see if that helps. – KC Baltz Mar 16 '17 at 20:46
  • 1
    @KCBaltz Can confirm... wtf – TrudleR Apr 3 '18 at 20:48
  • TrudleR's comment brought me back here. I don't have this problem with Steam anymore, so checking and unchecking must have fixed it. – KC Baltz Apr 5 '18 at 1:06
  • Does not work in macOS – timothymarois Aug 7 '18 at 11:56
3

For Mac users:

  1. Go to the  Apple menu and choose “System Preferences”, then go to “Users & Groups”
  2. Select the user that is active in OS X, then choose the “Login Items” tab
  3. Select “Steam” from this list and then hit the Delete key on the keyboard to remove steam from the automatic launch on login list
  4. Close out of System Preferences

protected by Frank Jun 10 '15 at 21:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.