1

I use Horses for followers mod, it works great, tried with Lydia. Now I made Ysolda my follower (she's a non-follower NPC in Whiterun) and she doesn't want to ride her horse. What can be the difference between Ysolda and Lydia? Anybody can tell me what to change?

  • If the mod is only for followers, and Ysolda isn't a follower, perhaps that's the problem? – Frank Feb 8 '13 at 13:13
1

AFAIK, Horses for followers mod works only for vanilla followers, meaning if you make any NPC that isn't a follower become your follower or adding additional follower into the game, this mod will not work.

Source: Experience. Installed mod and Dawnguard DLC. Serena won't ride horse with me :(

  • I think you should try it again with Serana, use the "Bill of sale" to change the ownership to follower, maybe that helps. And try mounting on your horse, than moving around her horse a little bit. – user42149 Feb 9 '13 at 9:54
1

Turns out this actually works with Ysolda =)

It just took time for her to get on the horse for the first time, but now it works great with my v1.8.x.x copy of Skyrim.

0

I had this problem as well. What you usually need to do is go to a stablemaster and choose the "I want to buy a horse for my companion" option. Then, get on your horse and move a little bit aways, and the npc should get up on the horse as long as he/she is a follower. Sometimes the npc takes its' time thinking if it wants to mount, but should after a little bit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.