3

Everytime I decreased my visual setting it maximizes the whole settings at every restarts. I dont know if I used a console command unintentionally. How can I solve this?

2
  • Did you add extra stuff, like autoconfigs or mods?
    – childe
    Commented Feb 13, 2013 at 16:00
  • @Retrosaur thanks.was using a different hud. write this as an answer so I can accept
    – emmett
    Commented Feb 15, 2013 at 12:14

2 Answers 2

3

Installing CSGO with custom HUDs will preload the conditions of the hud everytime you run the game. Some HUDs are more demanding than others, and will amp up your graphics everytime you run it, while some are less demanding.

Just uninstall your HUD, and you should be fine. If you don't know how to uninstall your HUD, an easier fix is to go to the Game Properties option by right-clicking the game in Steam, then click Validate Game Files. This will check for discrepancies in your game client and the actual game, and reset your settings accordingly.

1
  1. Change your CS:GO video settings in-game according to your preference.

  2. Alt+TAB to Windows.

  3. Go to C:\YourSteamFolderHere\userdata\765****\730\local\cfg in File Explorer.

  4. Right-click "video.txt" and select Properties from the bottom of the menu.

  5. Above the OK-button, select Read-only, then press OK.

Voilà, your video settings won't reset anymore.

To change your settings again, you have to uncheck Read-only before you change them, then put it on again.. Marking "video.txt" 'Read-only' means that the game nor you cannot write to the file.

1
  • I don't know why this is not the accepted answer but great! Works perfectly! Commented Apr 19, 2021 at 14:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .