I downloaded EA's free Command & Conquer: Tiberian Sun release, but when I try to run it, it complains of missing or broken DLLs. I tried to run the DLL regfix file, but it errored saying it could not access the registry. What do I do to fix it? I don't think the answer to this question would help (I don't think what I have is Command and Conquer Gold).

  • Have you got Windows 7 professional and therefore the "XP Mode" virtual machine? You could try installing it there instead... Nov 10, 2010 at 14:02
  • @Graham: I think I do, but i'm currently borrowing a friends machine and i'm trying to stay "low impact" :)
    – RCIX
    Nov 11, 2010 at 0:44
  • @GrahamClark, it wouldn't work in the XP Mode virtual machine. It doesn't support any 3D acceleration.
    – Dracs
    Nov 27, 2011 at 1:41

3 Answers 3


Right click and run as administrator, but be aware the game is not compatible with 64 bit versions of Windows 7.


Run in Windows XP compatibility mode, then it'll work on Windows 7 64bit. I tested it, and it worked correctly.


Try 3d analyzer, lower the resolution and then try changing the compatibility from Windows 7 to XP.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .