I have a served hosted at Fragnet.net. Here the default admin tool is McMyAdmin.

I want to set up permissions in MyMcAdmin with group manager as suggested by the fragnet knowledgebase. But even after following the steps described in the post I'm still having problems with my permissions. This is what I have done in McMyAdmin :

  1. Configuration --> Server Type --> CraftBukkit
  2. Configuration --> Features --> Permissions exporting mode --> GroupManager
  3. Configuration --> Plugins --> (I have installed the following plugins)

    • ChestShop 3.50
    • CommandBin 3.31
    • Essentials 2.10.1
    • EssentialsAntiBuild 2.10.1
    • EssentialsChat 2.10.1
    • EssentialsGeoIP 2.10.1
    • Permissions 3.1.6
    • GroupManager 2.0 (2.10.1) (Phoenix)
    • EssentialsProtect 2.10.1
    • EssentialsSpawn 2.10.1
    • EssentialsXMPP 2.10.1
    • iConomy 7.0
    • BukkitCompat r22a
    • Shopkeepers 1.11
    • TobiMotd 2.4
    • Vault 1.2.23-b301
    • WorldEdit 5.5
  4. In Users and Groups I have set up the following groups:

    • Administrators
    • Moderators
    • Regulars
    • Everyone

All the players are in the Everyone group at the moment and I have also added * in players to indicate that this is the default groups.

I am in the Administrators group with * and bukkit.command.* in permissions

The rest of the players don't have any specific permissions.

The problem is that no matter which permissions I give the players they don't get the permissions.

Can anybody tell me what it is that I'm doing wrong ?

I have tried asking the same question in the Fragnet forums, but I'm guessing that I might have more luck here.

  • 2
    Don't use * as a permission node! With some plugins, you are granting permissions you don't want. Whenever possible, assign the permissions you want. More work, but it makes life easier for you in the future.
    – Kaz Wolfe
    Commented Dec 15, 2014 at 19:14
  • @galacticninja - This is a server configuration question, not a "technical support" one
    – Robotnik
    Commented May 28, 2015 at 8:10
  • @Robotnik I see. My bad, then. Commented May 29, 2015 at 5:50

3 Answers 3


My issue was somewhat different, as my server was running forge, and forge and bukkit do not play well together, however this is what solved my issue.

  • I installed MCPC+, because it allows Forge and Bukkit to play nicely together. This probably wont be necessary if your only running Bukkit.
  • I installed the appropriate plugins using my MyMcAdmin Interface. It is important that you make sure you have the appropriate plugin versions to match your Minecraft version, for example the OP mentions he has the plugin Permissions installed, which is outdated and conflicts with Group Manager.
  • I set MyMcAdmin to output it's permissions to Group Manager
  • I created my Groups. This is another key point as there are many rules to follow or else MyMcAdmin and Group Manager don't wont play nicely.
    • You should have only one default group, it should inherit its permissions from none, and this group should have only one player in it, named "*". No other group may inherit its permissions from none, or have "*" in its Players column.
    • Each other group should inherit is permissions from whatever appropriate group you choose.
    • Every group should have its world specified in your World column.
    • Group names cannot have spaces or special characters in them.
    • Permissions should only show up in one group at a time, if multiple groups are intended to share permissions the inherit feature should be used.
  • If your world has multiple dimensions some config modification may be necessary to transfer permissions to all the appropriate dimensions. (IE: The Nether, The End, Myscraft Worlds, Dimensional Doors Pocket Dimensions, ect.) Further information on how to do that may be found here.

Hope this helps.


Do you have FTP access? I suggest test and add the perms in MCMA and then download the perm file and see if it is actually working. I don't know much about group manager, but does it store perms and doesnt it conflict with permission 3.16, which is seriously out of date and not compatible with the new bukkit perms.


Make sure you are putting the permissions in the permissions file. Plugin configs usually don't control permissions. Hope this helps!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .