In Channelwood in Myst a particular lever doesn't appear to be working. The explanation for my problem contains a spoiler, so I've hidden the text below:

There is a lever on the second level in one of the huts. I pressed it and saw something happen across the way next to the spiral staircase. But navigating back to the spiral staircase (still on the 2nd level), nothing appears to change. But consulting hints and walkthroughs, everything says the pressing that lever is supposed to open the door in front of the spiral staircase. I tried going back and pressing it again just in case I accidentally double-pressed the first time or something, but the door never opens.

Am I missing a key step here? Or could this be or is this a known bug?

I'm playing Myst on the iPhone in case that makes any difference. I don't believe it should, since the content of the game should not be any different.

  • It looks like this was a bug of some sort. I started a completely new game, and did the minimal steps necessary to go directly to Channelwoood and then striaght to that lever. Pressed it, and voila, the door opened. Reloaded my original game and tried again one more time, and confirmed for sure that the lever simply doesn't work in my game, it plays the door-open animation but the door doesn't actually open. Anyway, can't reproduce the problem and glad I can at least finish the game by re-playing through my new game (kind of annoying though). Will flag this question as Too Localized. – Ben Lee Mar 5 '13 at 16:23
  • Moderator: I've flagged this as Too Localized as it appears to be a non-reproducible bug, and not something other people will encounter or have encountered. – Ben Lee Mar 5 '13 at 16:25
  • That it is a bug and that you found a fix are both potentially useful to other people, so I'd say this is not too localized. You can leave it open, and I'd go so far as to post your own findings as an answer, should anyone else encounter this issue. – agent86 Mar 5 '13 at 16:28
  • @agent86, ok, will do. – Ben Lee Mar 5 '13 at 17:44

This appears to be a bug. If it plays the door-open animation, the door should end up opening. It's unknown what sequence of events or factors cause this bug to occur. But it can definitely be avoided by doing this action as the very first thing in the game. Of course, most sequences of game actions will avoid this bug since I've not been found any other reports of this online, but to definitely avoid the bug, the minimal sequence works. That is, perform the minimal sequence of events necessary to get to Channelwood and then from there, perform the minimal sequence of events necessary to get to the lever.

It may be possible to avoid this bug just by loading to an earlier save point (instead of restarting) and again performing the minimal steps from there. Unfortunately, I didn't have an earlier save game to test this myself, but it's quite possible the bug is only triggered by a certain sequence of actions in Channelwood itself.

I did eventually manage to finish the game by doing that lever in Channelwood first.

  • Confirmed this analysis. Myst on iOS 1.8.0 (24). Seems like a game state bug unless there is some unknown cruel trap. Fresh game and the lever works first go. – javabrett Feb 2 '20 at 4:51

If this is the lever you mean, once you've pulled the lever to unlock the door, your next step is to go back down the stairs and divert water power to the elevator.

Since you can only have power flowing to one piece of equipment at a time, the function of the stairs is to allow you to move between levels without using the elevator.

  • 1
    That is the lever I mean, and that next step makes sense, but my problem is prior to that step. The door to the stairway itself never seems to open. – Ben Lee Mar 3 '13 at 16:38
  • This is the standard path, but if you hit the apparent have state bug above, you will not be able to open the door at the top of the stairs. – javabrett Feb 2 '20 at 5:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.