Apparently, there is no easy way to change the interface language of SimCity. I had installed it via Origin on Windows 7 system. OS interface is in English, but locale is different, therefore, Origin had its interface in my native language, and installed SimCity localized as well.

There is no language settings in game, and changing Origin’s language did not get me anywhere. It looks like the game was installed with a single language identification that is located in %ProgramFiles(x86)%\Electronic Arts\SimCity\SimCity\Locale\[ISO language-locale code]\ (single Data.package file, about 512 kb).

So I am trying to determine if there is an easy(-ish) way to change the language on as-needed basis without changing OS locale settings or reinstalling the game.


Changing locale/language in Origin and reinstalling SimCity at least gave me the option to select installation language. I know it's not quite what OP was looking for, but I did get rid of the horrible Swedish translations, for what it's worth.


If you log in at profile.ea.com, you can change your country and language setting to what you prefer. Then uninstall the game and the installer. When you re-install, it should be in the selected language and it will also auto apply to other games you buy.

Courtesy of the EA helpdesk, so I hope it will work. Spent too much time waiting on the phone to keep this info for myself.

  • My language setting is "English" there, as it should be, but the first time I installed SimCity Plus from Origin and tried to play it, it told me "The product code you have redeemed for SimCity does not support the currently selected language." – Sarah Vessels Jun 11 '14 at 18:47

Change the language setting in origin and reinstall the game.


I don't think changing the language in Origin is enough. What I did was to use regedit to change the two entries listed above by antiall, i.e. GDFbinary to "GDFBinary_en_US.dll" and Locale to "en_US".

Afterwards, go to your origin folder and delete the entire Sim City folder and then redownload the game.

As both the language option is broken (there is none) and the repair option will not notice, let alone repair you deleting only the Locale folder, this appears to be the only way to force a language change. Well done EA, welcome to a world where people don't want to be told what language to speak based on an IP address ...

  • I have found the "GDFBinary_en_US.dll" ,but not the locale one can you be more specific please. Oh and by the way if this work you are my hero now – user43514 Mar 8 '13 at 14:15

protected by Community Mar 8 '13 at 16:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.