I didn't complete the quest 'Talk to Alvor in Riverwood' because I accidentally stole from the bartender and now I can't turn in my quest.

What can I do to fix this?

  • Can you pay you bounty in Riverwood? – aviangentile Mar 7 '13 at 18:45
  • idk the good thing is that riverwood doesn't hate me anymore but the bad thing is i cant complete the quest even if i talk to him – soulreaper Mar 8 '13 at 18:09
  • i think i already have and i think everyone hates me because i have really high bounty (around 15,000) and when they attacked me i attacked them and killed about 3 guards and 4 people in solitude, riften, and dawnstar and now they hate me because i killed guards and stuff – soulreaper Mar 8 '13 at 18:16
  • now i store ALL my gold in my base/camp which is knifepoint ridge – soulreaper Mar 8 '13 at 18:17
  • UPDATE now river wood hates me and i got so ticked off i killed everyone except the two kids and delfine or whatever her name is (i know i couldnt kill her because she helps me defeat dragons and stuff but i dont get why i cant kill kids) – soulreaper Mar 11 '13 at 17:27

It seems that there's a bug, have you tried this? http://forums.nexusmods.com/index.php?/topic/458210-talking-to-alvor-bug/

This guy exhausted every conversation and the arrow still appears over him, the answer was:

  • Talk to him
  • take all his supplies
  • exit trade window (where you take his supplies)
  • DONT touch keyboard/controller, he will start the dialogue by him self
  • let him do dialogue, wait for him to finish --> Questupdate

Also, have you tried to pay the fine? Take a look at this, this guy had a similar problem: Alvor keeps trying to kill me, can't advance the story. Although his problems were because he went murdering people before talking to Alvor, so that everyone wanted to kill him... but maybe some of the answers can help.

If nothing works, then maybe the game is ruined and you have to start all over again s:

| improve this answer | |
  • Hey, @Eirikra, could you summarize what you found in those links? We don't want to suffer from link rot, and when possible, want to have as much information on site as possible. – MBraedley Mar 7 '13 at 20:27
  • Oh yes, I'm sorry I'm new here hehe. I will do it right now :) – Opponent019 Mar 7 '13 at 20:34
  • i will try the bug thx – soulreaper Mar 8 '13 at 18:11

A lot of people restart the game, even at level 50 or so. So you need to restart to the last save that you had before you completed that quest.

If you delete the save, well... you're gonna have to restart from scratch.

Sorry if this happened to you.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.