I'm new to Dwarf Fortress, and though I've started a nice fortress, for some reason my dwarves are always starving. According to my records, there is plenty of food: over 100 in the "other" category, over 300 seeds, and over twenty drink plus a well and a river. But I constantly receive messages that "Urist McDwarf cancelled Give Food: no food available" and "Urist McDwarf cancelled Drink: no water source". Some are even hunting vermin. I think I'm getting the same problem with wood, because my carpenters are always cancelling tasks due to lack of wood even though there is a pile of it right outside the fortress door.

I already tried to remove walls and obstructions inside the fortress, but it didn't help. Moving, adding, and configuring stockpiles also didn't help. I see dwarves going to all of the locations of the things they need, but they almost never pick them up.

I'm using the Linux version. I don't know if it has more glitches than the Windows version.

EDIT: I just embarked in a new world, and several minutes later my carpenter cancelled a task I gave him, claiming that there wasn't enough wood even though I confirmed that the wood was available before assigning the task. A while after that, I started a stockpile underground, and I started getting error messages telling me that items couldn't be moved to it. There are huge paths with no blockage.

I'm considering the possibility of a limit on the path-finding system that scales with processor power (which would give me shorter paths, because my computer is old). This article says that the algorithm has been known to fail more generally: http://www.gamasutra.com/view/feature/131954/interview_the_making_of_dwarf_.php?page=8

I might be able to fix it by clustering my fortress. I'll try it tomorrow.

  • maybe it's forbidden? Mar 10, 2013 at 17:10
  • I don't forbid anythng. I haven't had a reason to yet.
    – Wutaz
    Mar 10, 2013 at 17:30
  • 1
    Have you dumped things? They will end up forbidden after they've been moved to a dump. Also, I don't think seeds are edible - cook some of them into roasts.
    – kotekzot
    Mar 10, 2013 at 17:32
  • @ratchetfreak The forbidden fruit much? c:
    – user37332
    Mar 10, 2013 at 17:38
  • 1
    Is this a reclaimed fortress? Dorfs won't touch anything old in a reclaimed fortress until you manually reclaim the items too. Alternatively, do you have any burrows set up? Any military alarms set on? Mar 10, 2013 at 19:12

4 Answers 4


A few things may be preventing your dwarves from eating the available food or drinking the available alcohol. The main two culprits are:

  • No path available to the item or its container.
  • Dwarves aren't permitted to travel where the food and drink is located.

Other things that stop dwarves from eating and drinking:

  • The food isn't edible to dwarves. Examples: Seeds
  • The drink isn't drinkable. Examples: Milk (shows up as other in foodstocks)
  • The item is forbidden.
  • The food or drink is claimed by a militia member as part of his/her food rations.

The dwarf fortress wiki has extensive articles on how to grow food, how to collect plants to eat or process (ie, cook in a kitchen) into edible food items, how to set up a still, etc. I'd suggest you look up plant collecting, still, food stock, and above ground farming. It is possible to farm underground, which uses a different set of plants (they can only be found in underground caverns or traded for with dwarven caravans) and requires easy soil layer access or making mud which sounds like it would just be an extra complication for you at this point in your dwarf fortress experience.


I've tried everything here, and I encourage everyone else with this problem to do so, but my problem seems to be caused by either a glitch or a limit on the pathing system.

I did find a solution: as long as the object the dwarf wants is very close, especially on the same z-level, the dwarves will be able to find it. I'm currently starting a new fortress based on this solution, and it's working well.

It's possible that most experienced players are already doing this to make hauling faster (and other benefits). If so, it would mean that everyone has the same problem, but they didn't recognize it because they already solved it.

  • I just saw a stockpile VANISH. That might be the problem!
    – Wutaz
    Mar 12, 2013 at 19:23

If you have a military with backpacks, they may have your food in there.

Go to the military screen [m] and hit [u] for supplies then use the [/] key to remove food from your squads.

Its always a good idea to use a kitchen and compile your foodstuffs into meals because it multiplies available options as well.


Some problems like these may be caused by, of all things, non vanilla graphics and tile-sets. A Some of these modify the raw files used by DF to determine reactions, such as what foods a dwarf may eat or how to brew wine, I surmise so they can animate that reaction when it occurs.

If the graphics you installed are not specific to your version of DF, it is possible they will break some of the game raws. It's probably best to download a specific version of DF and the graphics designed for that version, and then not change the graphics after that until/unless you go to a new version of DF.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .