I get this error fairly often, usually in less than 10 minutes of gameplay:

UT2004 Build UT2004_Build_[2005-11-23_16.22]

OS: Windows NT 6.2 (Build: 9200)
CPU: AuthenticAMD Unknown processor @ 3601 MHz with 4095MB RAM
Video: NVIDIA GeForce GTX 670 (1407)

CreateTexture failed(8007000E).

History: FD3DTexture::Cache <- FD3DRenderInterface::CacheTexture <- FD3DRenderInterface::HandleCombinedMaterial <- FD3DRenderInterface::SetSimpleMaterial <- FD3DRenderInterface::SetMaterial <- USkeletalMeshInstance::Render <- FDynamicActor::Render <- RenderLevel <- ONS-Dawn-t32-Beta3.myLevel <- FLevelSceneNode::Render <- FPlayerSceneNode::Render <- UGameEngine::Draw <- UWindowsViewport::Repaint <- UWindowsClient::Tick <- ClientTick <- UGameEngine::Tick <- Level Dawn <- UpdateWorld <- MainLoop <- FMallocWindows::Free <- FMallocWindows::Realloc <- 10910191 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free

Appears to be some kind of memory issue? My computer is way beyond the system requirements of UT2004. The game has dozens of graphics settings, so I don't know where to start. Is this error message associated with a specific setting?

One thing that stands out is 4095MB RAM -- I actually have 8 GB.

  • 1
    4 GB RAM isn't that surprising to me - UT04 is a 32 bit program. Have you tried running as admin and in compatibility mode?
    – CruelCow
    Commented Mar 13, 2013 at 1:06
  • Is your Windows 32 or 64 bit? Commented Mar 13, 2013 at 3:11

3 Answers 3


I was able to solve this problem by switching to the 64-bit client.


The game couldn't allocate Memory for a texture for whatever reason. The first Thing I'd try to do would be using one of the other renderers. It's been some time, but I think I remember there being a renderer option to pick DirectX or OpenGL (I might be wrong though, has been years since I played that game).

You might as well have luck updating your graphic card drivers. If you never installed new drivers since the Installation of Windows 8, chances aren't that bad that you're still running the stock drivers that might be outdated, more or less beta or simply incomplete.

Another option would be trying to use Windows' compatibility mode. First of all try to set the compatibility mode to Windows 7. If that doesn't work or the game still crashes, try to set it to Windows XP.

Having it list only 4 GB is perfectly fine, it simply isn't able to address more memory due to the way the executable has been created (32 bit etc.).


Typically this error is related to the limitations of 32-bit address space; by default UT2004 is limited to 1GB. On 64-bit Windows, you can set the "Large Address Aware" flag in an executable to allow the program to address up to 4GB using this program. With LAA, UT2004's limit will increase to 3GB. You can also do this for UnrealEd and UCC as well if you use those (or any other 32-bit program).

Here is another common error associated with this limit:

  • Ran out of virtual memory. To prevent this condition, you must free up more space on your primary hard disk.

The 64-bit executable is of course another solution, which comes with patch 3369.

  • Worked well for Fallout 3 and Skyrim. Not sure if it helps in this specific case, but it's a good option to try. +1
    – Joachim
    Commented Apr 12 at 11:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .