Left 4 Dead 2 Crashes PC

After a recent video card installation, Left 4 Dead 2 (L4D2) has been crashing my PC after loading a level. This is not a crash to desktop, rather a complete system crash: screens blanks and whatever sound was playing the background starts looping.

Reinstalling the game after deleting it from Steam and removing related application data in C:\Users did not correct the issue. Completely removing all of the Steam’s games and associated application data, then reinstalling did not correct the issue.

No other game (Skyrim, ArmA II, Borderlands 2, et al.) seems to be having trouble. Other Source engine games (Portal 2, CS:GO) run with no issues.

The drivers from ATI are the most current available, the operating system is up-to-date, Steam and L4D2 are updated dynamically.

These are the system specs from dxdiag:

Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.130104-1431)
System Manufacturer: Gateway
System Model: DX4860
BIOS: BIOS Date: 04/07/11 10:18:44 Ver: 04.06.04
Processor: Intel(R) Core(TM) i5-2300 CPU @ 2.80GHz (4 CPUs), ~2.8GHz
Memory: 6144MB RAM
Available OS Memory: 6126MB RAM
Page File: 3080MB used, 9171MB available
DirectX Version: DirectX 11

Card name: AMD Radeon HD 7700 Series
Display Memory: 3814 MB
Dedicated Memory: 1007 MB
Shared Memory: 2807 MB
Current Mode: 1920 x 1080 (32 bit) (60Hz)
Monitor Name: SyncMaster P2770HD/P2770(Digital)
Output Type: DVI Driver File Version: 8.17.0010.1172 (English)
Driver Version:
DDI Version: 11
Driver Model: WDDM 1.1
Driver Attributes: Final Retail
Driver Date/Size: 12/19/2012 15:08:04, 1151488 bytes
D3D9 Overlay: Not Supported
DXVA-HD: Not Supported
DDraw Status: Enabled
D3D Status: Enabled
AGP Status: Enabled

Any ideas?


2 Answers 2


Roll your drivers back to your previous version and see if the problem still persists. If so, it might be a recent patch for L4D2 that made it incompatible with something in your system. If possible, you could check the Event Viewer to find out what happens.

  • Go into Control Panel, and ensure "View by" is set to "Small icons" or "Large icons". "Category" won't work.
  • Click "Administrative tools", and then Even Viewer. In the left pane, expand "Windows logs" and then click "Application".
  • Give it some time to load, and find a log entry pertaining "left4dead2.exe" (or whatever L4D2 calls its executable, 'cause I'm just guessing that name there). A tip is to just invoke the problem you're experiencing, note the time down to the minute, and look for the log entry in the Event Viewer sorted by time.
  • Rolling back the drivers from the control panel seems to have worked. Although it was a brand new install, so I'm not sure what it rolled back to.
    – Chance
    Jul 30, 2013 at 22:30
  • Well, technically, it doesn't roll the drivers back to a previous version that was installed on your computer, but rather the previous version of the driver in general, regardless whether said version is a version you have had on your computer or not.
    – Gipphe
    Aug 16, 2013 at 19:43

A simple google search for "Left for Dead 2 Crashes Loading a Level" brought me a TON of information.


 ~"Just delete the video and video defaults files. This is how to get there: 

C://programs (x86)> Steam>Steamapps>common> left 4 dead 2>left4dead2>cfg

Scroll to the bottom of that and delete video and video defaults.

 ~Turn off Multicore Rendering.

 ~Type "mat_queue_mode 0" in console.

 ~It may be a L4D2 bug. Maybe it is incompatible with your hardware

(which I HIGHLY HIGHLY doubt)

~If none of these work, Use Google! :D

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .