I just arrived at the Memorial Gardens cemetary, and have had the game freeze three times. The first couple of times through, I was looting corpses before approaching the gate for the main objective. Both times, the prompts stopped appearing when you looked at a corpse, then the loot prompt stayed on the screen and wouldn't go away. I tried pausing the game, to see if a screen change might clear things up, and that's when it froze. This happened twice. I powered the system down and restarted from the last checkpoint.

The third time, I went directly for the main objective. This time the prompts stopped at the main gate, I just continued by pressing the Use button when it was apparent I needed to interact with something. The boss battle began and the game froze when I brought up the vigor selection wheel.

I'm stopping for now, hoping someone knows a way around these glitches.

Update: Using the last strategy I mentioned, I booted up the PS3, restarted the last checkpoint and immediately ran to the main gate to see if I could somehow make it through this level. After several game freezes, I finally got to the boss fight and brute force fought my way through with the two weapons I had in stock - the Heater and a shotgun. I died a couple of times, but was able to finish without bringing up the vigor select wheel or other loot menu. I did respond to Elizabeth providing me health and salts during the battle, and fortunately that worked. I got through to an auto-save, so now I'll see if the problem was that particular map or not.

Update: Well, the last auto-save file is corrupt and hangs during load. Looks like I'm starting back at an earlier chapter.

2 Answers 2


It appears that the game freezes were related to a corrupt auto-save file. As mentioned in my question updates, I had to revert to an earlier chapter which took me back to the beginning of the level, Downtown Emporia. I replayed through Comstock Gate, where the corrupt auto-save had occurred, and this time things were fine. I was able to play through the Memorial Gardens without incident, and appear to be on my way.

TIP: One thing I learned through this experience (having to replay things several times and dying multiple times along the way), is to keep my cash level at a minimum before large battles or boss fights. You scrounge every dollar you can, and don't want to waste it on resurrections. In Normal mode, anyway, you resurrect even when you have no cash. Spend it on weapon upgrades before the battles, and go into the fight with empty pockets!

  • Well, the problem came back, after exiting Memorial Gardens to search for the three tears. After the battle following the second tear, I encountered another corrupt auto-save, where the game won't load. I replayed from the previous chapter, which is now Memorial Gardens, and can't get past the second tear without the game freezing. This is ridiculous.
    – Alan
    Commented Apr 12, 2013 at 4:15

Probably late on this but did you erase the game data or clear your cache, that's helped me with other games, unfortunately with Bioshock Infinite I kept getting freezes in Soldier's Field now suddenly my ps3 won't read the disc or any other game disc now. Worked fine until then

  • Thanks for the tips, I hadn't tried either of those. I gave the game to a friend to see if he has better luck on his system, and watched the walkthrough videos on IGN to see how the game ends.
    – Alan
    Commented Apr 26, 2013 at 5:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .