My Playstation 3 bit it recently. It was one of the original 60 GB machines. When I try to turn it on, it flashes a bit, beeps three times, and flashes red. I've searched this out, and it's well-known that this means sending it back to Sony for a minimum charge of $150.

I decided to buy a new one, get the 300 GB drive, and also the Move package. I'm happy with the decision. Life should be great.

My GameFly disk is stuck in the old PS3. I guess I could just take an axe to the damn thing. Short of physical damage, though, is there any way to hold down buttons or put the PS3 in some mode where it ignores everything else and ejects the disk?

2 Answers 2


Check out the guides on iFixIt.com

The first screw is a T10 Security Torx screw, but a normal T10 Torx screwdriver should remove it. Honestly if you can get the screw out it's not super vital to get it back in so using a flathead and stripping it a bit whilst you remove it isn't too big of an issue.

If you have a heat gun and thermal paste try reflowing the cpu/gpu. You can probably get it working long enough to get your disc out, and maybe even back up your saves.

If not, just follow the tear down guide until you can get the disc drive out. The disc drive isn't too hard to disassemble, and you probably aren't too worried about getting it back together.

  • 2
    Yeah, that's what I just did. I got the disc! Nov 22, 2010 at 4:22
  • 3
    – aslum
    Nov 22, 2010 at 7:17

Have you tried holding down the eject button for 10 seconds? This will supposedly force eject any disk inside.

Also, according to a post in this thread, if you have a model of PS3 that allows fan test mode, try turning off the PS3 via the switch in the back, and turning it on while holding the eject button. It apparently runs a fan test and will eject the disk inside.

  • This doesn't have any effect. I tried doing this to start it up, while it was going through the startup, and afterwards when it was just flashing red. Nov 22, 2010 at 3:18
  • The fan test mode doesn't start. It acts just like normal.Green light, yellow light, flashing red and three beeps. Nov 22, 2010 at 3:20
  • The original 60Gb PS3 models don't support this, unfortunately. I guess Sony added this feature later after realising that their console wasn't bullet-proof after all. Sep 19, 2012 at 2:19
  • +1, just starting the console by pushing eject worked for me
    – Robotnik
    Apr 10, 2013 at 1:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .