Possible Duplicate:
The Age of Empires II Scrolling Bug

I'm trying to install Age of Empires II on Windows 7.

The graphics are so so, but when I enter a tutorial, the map keeps panning continuously, to the upper left of the screen especially. It doesn't seem to be the mouse, I have lifted it off of the pad, and it still pans automatically...

What can I do to fix this?

  • do you have a game pad, flight stick or other peripheral attached?
    – Xantec
    Nov 22, 2010 at 22:06
  • @Xantec: nope....
    – studiohack
    Nov 23, 2010 at 14:09
  • I have just upgraded to Windows 7 and am gonna try AoE-II this weekend. I'll let you know of my experience when I do that.
    – Aaron S
    Jan 20, 2011 at 9:59
  • that would be awesome @6packkid
    – studiohack
    Feb 20, 2011 at 21:53
  • Worked fine for me. I have even played multi-player at Voobly and it worked fine.
    – Aaron S
    Feb 21, 2011 at 16:08

5 Answers 5


I don't think its Windows 7 actually. The scrolling glitch is something that happened back in the XP days as well.

Do you have a Zune? A lot of people who have experienced the scrolling glitch have had Zunes, and after uninstalling the Zune drivers and software the problem has been fixed.

Another fix that used to work for people was powering off the computer, unplugging all peripherals, then once you get to the desktop/login screen, plug them all back in. You might try that as well.

  • 1
    jaw drops This may have something to do with Zune? interesting! I have several Zunes and use them with my machine frequently... +1 for the answer, will have to try some of these things!
    – studiohack
    Mar 18, 2011 at 23:11
  • Yeah, its one of the weirder problems I've seen. The only reason I know about it is that I had a friend who had the same issue a few years ago.
    – Weegee
    Mar 19, 2011 at 1:04

have you tried modifying the shortcut to use compatibility modes for previous windows versions?

  • I've tried running it in compatibility mode for Windows XP SP3...but no luck
    – studiohack
    Nov 22, 2010 at 22:16

I have found a fix for this:

I did not have to uninstall zune to fix it either.

I believe that it is one of the Zune processes that is causing the scrolling problem. If you don't start zune(and kill all processes) Age of Empires II will work.


There doesn't seem to be any documented fix(es) anywhere for installing Age of Empires II on Windows 7...so will stick with Windows XP for that!


That scrolling bug should be fixed by the community-made (non-official) AOE II: The Conquerors patch, UserPatch | https://userpatch.aiscripters.net/ :

This is a feature and bug-fix update for Age of Empires II: The Conquerors Expansion. Its primary focus is to correct several long existing issues with the AI system and related game elements.

Among many other fixes and improvements to AOE II: The Conquerors, one if its core features is:

Uncontrollable game view scrolling bug has been fixed

Note that the UserPatch installer must be run with admin privileges in order for it to be able to install all of its fixes.

Not the answer you're looking for? Browse other questions tagged .