I've just decided to re-install RCT onto my system for a little fun.. All works fine and dandy (I bought it off of GoG.com, so it was downloaded up-to-date), the only issue I'm having is that the game tears TERRIBLY when I move the scene. I don't remember if this happened on my old computer (which probably wasn't running it at mind blowing FPS) but I did try limiting the FPS with afterburner. But yeah, it's that old that afterburner couldn't hook up to it.

I also tried DXtory, but that program loves to crash. I tried forcing vsync in Nvidia control panel, but that didn't help at all.

How can I fix this problem?

  • have you tried playing windowed mode?
    – Rapitor
    Commented May 6, 2013 at 20:17
  • @JLaBella RCT doesn't support windowed mode, unless you plan on playing the game through a virtual machine.
    – Nolonar
    Commented May 6, 2013 at 20:23
  • I play it on windowed mode... You just have to add -w to the shortcut properties(in the target directory) and its golden, because I was having tearing issues as well. Windowed fixed me up
    – Rapitor
    Commented May 6, 2013 at 20:24
  • 2
    @JLaBella That sounds like more of an answer than a comment. :) Commented May 6, 2013 at 21:22
  • What's your current OS and configuration ?
    – Xaltar
    Commented May 7, 2013 at 9:33

2 Answers 2


Try these:

Compatibility modes

Setting the game to run in compatibility mode can help fix many issues with launching and playing the game. To do this, right-click the .exe, open Properties and set the game to run in Windows XP SP2 or Windows XP SP3 compatibility mode from the Compatibility tab.

Desktop composition

Some problems can be caused in Windows 7 and Windows Vista by having desktop composition enabled. To turn this off, check the 'Disable desktop composition' option from the Compatibility menu (right-click .exe > Properties > Compatibility).

Source: PC Gaming Wiki, "RollerCoaster Tycoon" article


There are official and unofficial patches for Roller Coaster Tycoon that could make it work better. The current official patch version is 1.08.187 – if your version isn't up to date, installing the most recent patch is the first thing to try.

If that doesn't help, you can try to:

  • Launch in Windows 95 Compatibility Mode
  • Disable Visual Themes in properties
  • Disable Desktop Composition
  • Run as Administrator (some restrictions make games unable to access some files)
  • Try a virtual machine (VirtualBox should do it)

They are also kinda unstable in a 64 bits environment.

  • 1
    The version that is sold by GOG is RCT Deluxe which includes CF and LL, so the patch branch OP is looking for is 1.20, not 1.08.
    – BoltClock
    Commented May 7, 2013 at 17:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .