After a reasonable hiatus from Blizzard games, I have decided to reinstall Diablo 3. I used to have it installed and working on this machine and removed my previous install using Add/Remove Programs. However, now when I try to reinstall the game, the Diablo 3 Setup starts 'Updating setup files...' and then hangs;

enter image description here

I have had a quick google for ideas on how to fix it which seems to bring up a bunch of posts when the server loads were really high last year, nevertheless I have been through the list of suggestions, making sure that secondary login is enabled, running the installer as administrator, etc.

After leaving the installer for ~30 minutes, it finally brings up an error stating it could not run the Blizzard agent;

enter image description here

This gives me an error code - BLZPTS00007 - which gives me a few more google hits including a seemingly official guide on how to troubleshoot agent issues on Battle.net, however performing the steps listed under 'Advanced Troubleshooting' still hasn't resolved my problem.

How can I get past "Updating setup files..." when reinstalling Diablo 3, and what is error BLZPTS0007?

  • Related: gaming.stackexchange.com/questions/65601/…
    – user9983
    May 15, 2013 at 19:57
  • Killing any of the agent processes that spawn (it spawns many) results in the launcher loading with an immediate error stating "There has been a communication error, please restart the launcher", restarting the launcher results in the process repeating again
    – kalina
    May 15, 2013 at 20:36
  • Did you try to remove D3 again, then manually delete all the files associated with it(don't know which ones exactly, but most probably in My Documents there will be a folder for D3)? Run CCleaner twice, then try it again. If it didn't help maybe there is a problem with the game disk? Try downloading an installer from Blizzard website. These were just some wild guesses, so I kept it as a comment
    – Novarg
    May 16, 2013 at 11:34
  • since it didn't "install" yet - there is no entry in add/remove programs. I have nothing in My Documents, I have the launcher files in C:\ProgramData and I have removed all of those, I have cleared all of my various temporary file locations as per the recommendations, rebooted, ensured that none of the files had returned, etc etc - still doesn't get past that screenshot
    – kalina
    May 16, 2013 at 11:36
  • What OS are you running? Windows 7 64bit I presume?
    – Alenanno
    May 16, 2013 at 14:33

1 Answer 1


For whatever reason, Internet Explorer (which I never use) was set to "work offline". For whatever reason, with Internet Explorer set to work offline, the Diablo 3 installer was failing to do anything other than time out.

I disabled "work offline" by unchecking "Work Offline" in the file menu (available by pressing the ALT key in newer versions of Windows/Internet Explorer);

enter image description here

Once this option was disabled, everything worked first time.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .