0

Since I installed Metro 2033 I can't play it comfortable because constant lags. I was looking for solution and I found only other people problems about frame drops. My problem is different, it's about micro-freezing while frame rate is still in constant value. The most strange thing about that is that I have these micro-lags also in main menu (very rare). Lags, like screen is frozen for less than half a second, getting worse (a lot of such lags) when I'm shooting enemy or people start to talk in the game.

My FPS is around 110-120 FPS and my PC config is rather good: Windows 7, 8GB Ram, Intel i5 3.1Ghz, Radeon 7850 so I believe it can't be a problem to have better graphic card or CPU. Am I right? Recently I bought SSD disk because I thought it's disk problem, but no success. Any advice what can I do more?

I uploaded video on youtube to show this annoying issue (with slow motion as well to make it easier to notice). Here is the link (watch in HD):

9
  • You meet the system requirements. Sounds like a disk access error, but you replaced your hard drive with SSD, right? Do you have any other HDDs in the computer?
    – Frank
    May 16, 2013 at 17:03
  • You say your FPS is about 110-120. What is the refresh rate on your monitor? Do you have vsync enabled? Do you have more than one video card in a SLI/Crossfire setup? May 16, 2013 at 17:04
  • @SevenSidedDie I have disabled vsync in Catalyst Control Center (I tried to have enabled, disabled - nothing works). I have only one graphic card. Game is installed on SSD Disk.
    – Lucas
    May 16, 2013 at 17:06
  • Does Metro have an internal vsync option? (Turning it off in CCC won't matter if it's turned on in the game's own video options.) Also, what exact brand and model is your Radeon 7850? Some card makers have been putting two GPUs on one card, effectively creating a Crossfire setup on-board. Unfortunately, this can be a source of microstutter. May 16, 2013 at 17:10
  • @SevenSidedDie It's Sapphire Radeon HD7850 2GB DDR5. In Metro I didn't find VSync option.
    – Lucas
    May 16, 2013 at 17:29

1 Answer 1

1

What helped for me with the micro-stutters in Metro 2033 was this guide in a GameFAQs forum post (which I found through PC Gaming Wiki):

I discovered that the user.cfg inside the game directory actually has many commands that slows down frame rates considerably. The configuration inside this directory is never used if not when the game is firstly started or when the user.cfg inside the Appdata is removed. As I said it contains many commands that greatly reduce frame rates. Problem is that if you just remove the user.cfg that it's used by the game all these commands will be recreated back and the performance of the game will be greatly reduced.

So I discovered that if you rename the user.cfg that recreates these commands (the one inside the game dir) and you delete the user.cfg used by the game you have an HUGE increase in FPS. However you cannot simply delete the user.cfg inside the game dir because it contains some keybindings that are not recreated by default by the game.

To cirumvent the trouble do this:

A) Under the game directory you will find the user.cfg I'm speaking about. Rename it to user.txt. We are doing this because on the next step we are going to delete the user.cfg actually used by the game, and if you don't rename the user.cfg inside the game directory the commands in it will be copied in the user.cfg recreated. However you cannot delete the file because it contains some keyboard binding nots recreated automatically by the game, you have topaste them manually.

B) Go under \Users\Username\Appdata\Local\4A Games\Metro2033\ directory. Be sure to have the ability to look hidden files or you will not see the "Local" directory and its content. Inside you will find the user.cfg used by the game. Delete it (yes, delete it, don't worry).

C) Start the game. You will notice that the settings will be reverted back. Just put all the settings as they were before. Now exit the game.

D) Return under the \Users\Username\Appdata\Local\4A Games\Metro2033\ directory. You will see that the file user.cfg has being recreated. This is fine. Now open another window and go inside the game directory. Open the user.txt (that it was user.cfg that you renamed). Now you have to past all "bind ..." keyboard commands (the one with "kX" as "kESCAPE" for example)inside the user.cfg file. You must do this because there are somebindings that as I said are not recreated by default. If you don't do this step for example the ESC key will not work to go to the menu while you are playing.

E) After you have finished pasting the bindings (it should begin with "bind changemenumap kESCAPE" and end with "bind wpn_aim mouse1", the rest you don't need since they are keypads bindings) save the file. You are done.

1
  • I did it and I have slight improvement, but still is a way not in the way I would like to have. Thank you for advice.
    – Lucas
    May 17, 2013 at 14:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .