Steam on my Mac is giving me the error *SteamStartEngine(0xbfb334f0) failed with error 1: CMultiFieldBlob(pSerialized) : Bad field -extends past end of blob. I have tried the terminal command, which did not work. I tried locating the Application Support folder, but could not find it. Even tried deleting it and reinstalling it. Anyone know what to do?

  • What terminal command? This one is for Ubuntu, which is why it doesn't work. – Jeffrey Lin May 19 '13 at 15:25

Steam Support has an article on this error: Steam.exe (main exception): CMultiFieldBlob(pSerialized). This is what is has to say about the cause and the solution for Mac:

This error results from a corrupted ClientRegistry.blob file, typically caused by Steam unexpectedly closing. This is often due to a crash or because the Steam.exe process was killed before Steam finished writing to the file.

Some instances of this error can be avoided by allowing Steam to fully exit by clicking Steam ▸ Exit or by right-clicking on the Steam icon in the System tray and clicking Exit, rather than forcing the process to end.

[…]

Solution for Mac

To fix this error use the following steps:

  1. Exit Steam
  2. Navigate to Users/[username]/Library/Application Support/Steam (by default.)
  3. Delete everything in that directory
  4. Launch Steam.app from your Dock or Applications folder

Note that this will uninstall all your games, and (depending on the game) might also delete configurations and saves! Despite this being the official fix, it doesn't mention that important consequence. Probably they want this to 100% fix any errors, but most errors will probably be fixed just by deleting the ClientRegistry.blob file and leaving everything else in that folder alone.

If really want to be sure that the error is fixed but you want to stay on the safe side, just move the SteamApps folder out of that one in step (3), instead of deleting it, and delete everything else. Do step (4), and verify that everything is working again without errors. Then shut down Steam, move the SteamApps folders back in, and see if it will still work without errors. If it does, then you're good. If not, then the problem is sadly somewhere in that folder and it probably can't be saved easily without a full deletion.

  • Note that following those instructions will delete all your installed Steam games (you'll have to redownload them) and in some cases your non-synchronized saves / configuration as well. – user2640 Jun 18 '13 at 20:19
  • @JoeWreschnig Good call. Those folders can be backed up and just dumped back in after step (4), right? I haven't ever had to, so I haven't the experience with it to say. – SevenSidedDie Jun 18 '13 at 20:30
  • Maybe? The one to keep would be .../Steam/SteamApps which has the game data and maybe .../Steam/userdata. But I would also guess that ClientRegistry.blob has to be synced with this somehow and without it, you might've just restored a bunch of files it will have to redownload anyway. – user2640 Jun 18 '13 at 20:51
  • @JoeWreschnig That should cover it. – SevenSidedDie Jun 18 '13 at 20:57

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.