5

I recently got a new computer (Mac) and tried to download Minecraft (which worked).

I then opened the .zip file, but after I put Minecraft into Applications and tried to open it, it said:

"Minecraft" is damaged and can't be opened. You should move it to the Trash.

I have no idea what caused this. Any help would be appreciated.

  • Have you installed Java? – Nolonar May 21 '13 at 20:16
  • 2
    Since when is Minecraft distributed in a zipfile? it has a jar for the launcher. (you download this from the website) and then when you run this the launcher will handle downloading all the other files. No zip-files involved. Java must be installed in any case though. – Arperum May 21 '13 at 20:38
  • @Nolanar yes I have java installed – Neffer_23 May 21 '13 at 20:46
  • @Arperum since now, I guess. You are talking mac right? – Neffer_23 May 21 '13 at 20:48
  • @GeloDCastroid9 You didn't seem to try the solution before accepting it... I put a more detailed answer. – user28379 May 21 '13 at 21:24
12

This is a problem caused by Mac OS X's GateKeeper setting.

Gatekeeper is a new feature in Mountain Lion and OS X Lion v10.7.5 that builds on OS X's existing malware checks to help protect your Mac from malware and misbehaving apps downloaded from the Internet.

This article is related to what you are experiencing.

This solution from minecraft.net seems to work for most people:

If you see a warning on Lion and above reading "Minecraft" is damaged and can't be opened. You should move it to the trash.", you have to set Gatekeeper to allow Minecraft as it is not yet certified as coming from a known developer.

There are two ways:

  • in System Preferences > Security & Privacy:
    Set "Allow Applications Downloaded From" to 'Anywhere'.
    You have to click the lock on the bottom to make changes. Once you start up minecraft.app , you can change it back to 'Mac App Store and identified developers'.

  • A different way is to right-click minecraft.app and click open. You will be asked for confirmation.


If the above doesn't work, try this first:

This will allow your minecraft.app to run:

chmod +x ~/Desktop/Minecraft.app/Contents/MacOS/JavaApplicationStub
| improve this answer | |
  • Thx it workes now – Neffer_23 May 22 '13 at 22:22
  • Talk about a silly "feature". Why ask if it's OK to open the thing and then deny it with a completely unrelated error message!?! Thanks for the info. – Marc-André Lafortune Jul 5 '16 at 21:24
2

The pack is corrupted. you should download another one since Minecraft is a small package so it won't take time to get another copy.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.