I am on 64-bit Windows 7 Professional.

I am unable to use the Steam client at all. The problem began when I loaded Steam today and went to my Library tab--it caused the client to crash. I do not have any custom games installed; only Skyrim which was purchased and downloaded through Steam. I had not done anything to cause this, it just crashed.

Following the crash, I reopened the client and continued to download the game I was downloading at the time (PlanetSide 2), only to find that it now would not download no matter what I did. I tried changing my download region and deleting ClientRegistry.blob, but its status stayed at Updating.... I decided to just uninstall Steam and retry from scratch.

After Steam uninstalled, I restarted my computer, then reinstalled it. Now when I try to open Steam it continuously opens, downloads an 8,691 KB update, says Extracting package... for several seconds, then completely closes.

  • VPN is turned off
  • All Steam ports are open through my router
  • Tried removing ClientRegistry.blob
  • Completely uninstalled antivirus and MalwareBytes
  • Tried uninstalling/reinstalling Steam using these instructions, didn't fix it

I have been trying to get this to work for a full hour and a half now, and I cannot get anything to work no matter what I try. Any advice at all would be incredibly appreciated.

  • 3
    Have you tried contacting Steam Support? May 26, 2013 at 22:10

1 Answer 1


I have now discovered the issue (after posting, of course). I have a Ralink RT2860 wireless card that I use to connect to the internet, and the newest (albeit three years old) drivers apparently cause the issue.

If anyone else has this issue, you can download the working drivers (version 3.0.11) from this link.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .