0

I get about 15-20 FPS in GTA IV. I should be able to run it on the highest setting with over 60 FPS.
I have tried to lower all the settings to low, but it doesn't improve my performance at all, not even by 1 FPS. I was thinking there was some sort of FPS limit somewhere; could that be the case?

Specs
CPU: Intel Core i7
GPU: Nvidia GeForce GTX 675m/ 2GB
RAM: 8GB

as you see the should be no problem...

  • 2
    This is almost guaranteed the exact same problem as your question about Skyrim. – Frank Jun 6 '13 at 18:15
  • nope i've checked the drivers 2 times this week. im not that derpy hehe – RustyMembers Jun 6 '13 at 18:17
  • Depends; does Skyrim stutter again? Did GTA stutter before the driver update? Perhaps one game works with the updated drivers, and the other doesn't. – Frank Jun 6 '13 at 18:21
  • skyrim works fine, and i have played GTA IV on the laptop before with no problem (a long time ago) – RustyMembers Jun 6 '13 at 18:23
  • are the drivers up-to-date? Are there no other heavy programs running at the same time? – Novarg Jun 6 '13 at 18:41
4

Without lowering your graphics

Right-click on GTA 4 in Steam, and click on Properties.
Click on Set Launch Options... and a window with a TextBox will appear.

In that TextBox, paste these arguments:

-nomemrestrict -norestrictions

Screenshot

and GTA 4 should run with a huge speedup.
On my rig

i7 3770K
32 GB RAM
GeForce GTX 680

GTA used to run on max settings at around 20-35 FPS.
With these arguments, it runs between 50 and 55 FPS and averages at ~52 FPS.

With lowering your graphics

Interestingly, GTA doesn't seem to care about GPU so much, as there is almost no difference between playing with a 1920x1080 or 800x600 resolution.
The only settings that seem to yield any significant increase in FPS is View Distance and Detail Distance, which should be lowered together. With both set to 1, my max FPS went from 55 to 140, although the average FPS only increased from 52 to 55. I wouldn't recommend setting them both to 1, as it can introduce some odd graphical glitches, such as signs seemingly floating in midair, until you get close enough for the sign's support to pop into view.
You might want to set the ingame option Definition: On, which will deactivate Motion Blur (yes, On == deactivate) and earn you an additional 5-20 FPS when driving fast enough for aforementioned Motion Blur to kick in.

About why GTA fails to start

According to this wiki the problem may be caused by an out-of-date GFWL client, or because of your MTU size.

  • Do you know how -precache helps improve performance? The PC Gaming Wiki only recommends -nomemrestrict and -norestrictions to improve performance. – galacticninja Jun 9 '13 at 14:18
  • @galacticninja I don't. I just found those 3 arguments somewhere on the net, and they helped. Didn't bother testing all possible combination to find out which worked best. Feel free to edit my answer, if you feel that -noprecache doesn't help (or even deteriorates performance) – Nolonar Jun 9 '13 at 14:29
  • I don't know what exactly -noprecache does either, so I won't edit. I just asked in case you know. – galacticninja Jun 9 '13 at 14:31
3

Grand Theft Auto IV had an awful lag that was fixed in a patch. Make sure it is up to date. I had the same issue ages ago and updating fixed it nicely. Hope this helps!

  • i installed the game 1 hour ago, so it should be up to date :D – RustyMembers Jun 6 '13 at 18:24
  • 7
    Sometimes developers don't include new patches in the installer. I would try looking for it. – CuddleBunny Jun 7 '13 at 13:26
  • @CuddleBunny - If it is a steam game, it should automatically keep itself up to date, unless you explicitly set it not to. – Robotnik Jun 21 '13 at 6:39
  • @Robotnik Yeah, but I wouldn't count on that. – CuddleBunny Jun 25 '13 at 20:34
3

Are you sure you are launching the game using you Nvidia Video card and not your on board laptop card?

Find the .exe that you are launching. Right click on and there should be an option open with Nvidia card.

1

I found a solution on this youtubevid:

Seems like the problem is windows keylogger. It worked for me, hope it'll work for you :-)

  • couldn't find the windows event log... the event collector is now disabled... the game still lags -.- – RustyMembers Jun 10 '13 at 18:59
  • is your windows in english? ..mine is not, so 'windows event log' were translated to danish. – ebbe777 Jun 11 '13 at 12:17
  • so what would the danish name for it be (from denmark too) – RustyMembers Jun 12 '13 at 17:36
1

What might be the case is having active Monitor Mirroring drivers installed and running. Some examples:

  • Teamviewer
  • LogMeIn
  • VNC

Any software that allows remote connections to see the desktop of your computer has the potential to cause such problems. Try uninstalling them, as simply exiting them does not stop the mirror drivers.

  • i dont have anyu of those programs installed... so i don tthink thats the problem – RustyMembers Jun 22 '13 at 8:41
1

I don't know how powerful your graphics card is, but have you tried lowering your resolution?

A lot of the time graphics cards aren't built to handle the higher resolutions when running a game.

  • 5
    This doesn't answer the question; it should really be a comment. – Frank Jun 20 '13 at 15:38
  • The answers that had been given all haven't helped him. So I thought outside the box. Sometimes it's the simple things that fix the problem. Not in depth stuff. – Charkz Jun 20 '13 at 15:41
  • The only part in your answer that actually addresses the question is the suggestion to try lowering the resolution. Everything else doesn't help answer the question, and that's why it should be a comment. – Frank Jun 20 '13 at 15:50
1

In the main GTA IV folder, create a text file and name it commandline.txt. Edit the file with a text editor, like Notepad to contain the following text:

availablevidmem 8

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.