0

I have 2 desktops and 1 laptop. My desktop runs windows 7, my wifes desktop runs window vista, the laptop runs windows 7. If I start a game and open it to LAN on my desktop both my wifes computer and the laptop can connect to the game. If I start a game on either my wifes computer or the laptop and open it to LAN, none of the computers can connect to it.

I know how to correct the 0.0.0.0 problem - this isn't whats wrong. Minecraft is allowed through the firewalls and router.

Can anyone help?

3
  • 7
    This does sound like a firewall problem. Are you super-sure that the ports are open?
    – fredley
    Jun 8, 2013 at 21:18
  • 1
    How about Windows? Is Windows set up to expect and allow connections to Minecraft? Is there any security software running that would intercept this?
    – Coronus
    Jun 10, 2013 at 19:30
  • I'm voting to close this question as off-topic because it would be more suited to SuperUser, being that it's related to Firewall configuration.
    – Neon1024
    May 28, 2015 at 11:06

3 Answers 3

2

Are you sure that you're allowed through the firewall?

There is an easy test to verify, if you have a telnet installed, and you if you know what port it's running on:

  1. From the machine that's running the server, bring up the command prompt.
  2. Type telnet localhost port` (replacing port with the port number)
  3. Look at the message you get.
  4. Repeat from the other machines, changing 'localhost' to the name or IP address of the server.

If it returns quickly with a 'connection refused' or sits for a minute or two before failing from the server, then it's either a sign that it's not really listening, or it's listening on a different port than you think.

If you're able to connect from the host, but then it fails on the other machines, then it's likely a firewall or similar, but it might also be a sign that you have the IP address of the server wrong also.

5
  • 1
    No telnet in Windows 7 - Have to be using XP Jul 18, 2013 at 12:49
  • 1
    @Neurofluxation : hmm ... it looks like you can enable it via the windows features control panel
    – Joe
    Jul 18, 2013 at 12:51
  • Oooh. I did not know that! But at the same time - didn't work for me on Win7 x64 Jul 18, 2013 at 15:08
  • @Neurofluxation in what way didn't work? If it's the telnet command, try using a colon between the host ('localhost' or ip address) and port number.
    – Joe
    Jul 18, 2013 at 15:22
  • 1
    PuTTy. That is all I have to say ;) ;) Jul 18, 2013 at 15:57
0

Turn all machines off and on again.

I recently had the same problem owing to my router thinking both computers were the same machine. After restarting the modem, router, and computer, it was resolved.

0

Make sure they're all connected to the same connection.

1
  • And using either WiFi or a proper cable type! Jul 18, 2013 at 12:49

Not the answer you're looking for? Browse other questions tagged .